glassfish
  1. glassfish
  2. GLASSFISH-10397

Connection Refused: Endless recursion in SerialContext

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v2.1
    • Fix Version/s: V3
    • Component/s: naming
    • Labels:
      None
    • Environment:

      Operating System: Windows Vista
      Platform: All

    • Issuezilla Id:
      10,397
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      Hi,

      There is an endless recursion within the method
      com.sun.enterprise.naming.SerialContext.lookup() line 436.

      The bug can be reproduced:
      0) Start Server
      1) Start Client Application
      2) Call Server using InitialContext lookup and HelloWorld EJB
      3) Shut down server
      4) Call Server using IntialContext lookup and HelloWorld EJB
      --> Call to 4) never returns

      The endless recursion is visible in following stack trace. Every two minutes the
      Corba call returns (Time Out) but instead of giving up the lookup method is
      called recursively.

      We are using Glassfish v2.1 b60e. Swing Application (Java 1.6) without ACC. We
      added following JARs to the Client appliation's classpath:
      appserv-admin.jar
      appserv-deployment-client.jar
      appserv-ext.jar
      appserv-rt.jar
      javaee.jar

      19.10.2009 16:00:08
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl <init>
      WARNUNG: "IOP00410201: (COMM_FAILURE) Connection failure: socketType:
      IIOP_CLEAR_TEXT; hostname: 192.168.73.114; port: 3820"
      org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2690)
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2711)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:261)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:274)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelContactInfoImpl.createConnection(SocketOrChannelContactInfoImpl.java:130)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientRequestDispatcherImpl.beginRequest(CorbaClientRequestDispatcherImpl.java:192)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientDelegateImpl.request(CorbaClientDelegateImpl.java:181)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.privateInvoke(StubInvocationHandlerImpl.java:186)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:152)
      at
      com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(BCELStubBase.java:225)
      at
      com.sun.enterprise.naming._SerialContextProvider_DynamicStub.lookup(com/sun/enterprise/naming/_SerialContextProvider_DynamicStub.java)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:409)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at ch.parametrix.test.GlassFish.callHelloWorld(GlassFish.java:24)
      at ch.parametrix.test.Main$1.actionPerformed(Main.java:23)
      at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
      at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
      at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
      at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
      at
      javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
      at java.awt.Component.processMouseEvent(Component.java:6216)
      at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
      at java.awt.Component.processEvent(Component.java:5981)
      at java.awt.Container.processEvent(Container.java:2041)
      at java.awt.Component.dispatchEventImpl(Component.java:4583)
      at java.awt.Container.dispatchEventImpl(Container.java:2099)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
      at java.awt.Container.dispatchEventImpl(Container.java:2085)
      at java.awt.Window.dispatchEventImpl(Window.java:2475)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      Caused by: java.lang.RuntimeException: java.net.ConnectException: Connection
      refused: connect
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:347)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:244)
      ... 46 more
      Caused by: java.net.ConnectException: Connection refused: connect
      at sun.nio.ch.Net.connect(Native Method)
      at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:507)
      at com.sun.corba.ee.impl.orbutil.ORBUtility.openSocketChannel(ORBUtility.java:105)
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:332)
      ... 47 more
      19.10.2009 16:00:13
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl <init>
      WARNUNG: "IOP00410201: (COMM_FAILURE) Connection failure: socketType:
      IIOP_CLEAR_TEXT; hostname: 192.168.73.114; port: 3920"
      org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2690)
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2711)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:261)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:274)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelContactInfoImpl.createConnection(SocketOrChannelContactInfoImpl.java:130)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientRequestDispatcherImpl.beginRequest(CorbaClientRequestDispatcherImpl.java:192)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientDelegateImpl.request(CorbaClientDelegateImpl.java:181)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.privateInvoke(StubInvocationHandlerImpl.java:186)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:152)
      at
      com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(BCELStubBase.java:225)
      at
      com.sun.enterprise.naming._SerialContextProvider_DynamicStub.lookup(com/sun/enterprise/naming/_SerialContextProvider_DynamicStub.java)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:409)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at ch.parametrix.test.GlassFish.callHelloWorld(GlassFish.java:24)
      at ch.parametrix.test.Main$1.actionPerformed(Main.java:23)
      at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
      at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
      at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
      at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
      at
      javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
      at java.awt.Component.processMouseEvent(Component.java:6216)
      at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
      at java.awt.Component.processEvent(Component.java:5981)
      at java.awt.Container.processEvent(Container.java:2041)
      at java.awt.Component.dispatchEventImpl(Component.java:4583)
      at java.awt.Container.dispatchEventImpl(Container.java:2099)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
      at java.awt.Container.dispatchEventImpl(Container.java:2085)
      at java.awt.Window.dispatchEventImpl(Window.java:2475)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      Caused by: java.lang.RuntimeException: java.net.ConnectException: Connection
      refused: connect
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:347)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:244)
      ... 46 more
      Caused by: java.net.ConnectException: Connection refused: connect
      at sun.nio.ch.Net.connect(Native Method)
      at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:507)
      at com.sun.corba.ee.impl.orbutil.ORBUtility.openSocketChannel(ORBUtility.java:105)
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:332)
      ... 47 more
      19.10.2009 16:00:14
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl <init>
      WARNUNG: "IOP00410201: (COMM_FAILURE) Connection failure: socketType:
      IIOP_CLEAR_TEXT; hostname: 192.168.73.114; port: 3700"
      org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2690)
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2711)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:261)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:274)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelContactInfoImpl.createConnection(SocketOrChannelContactInfoImpl.java:130)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientRequestDispatcherImpl.beginRequest(CorbaClientRequestDispatcherImpl.java:192)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientDelegateImpl.request(CorbaClientDelegateImpl.java:181)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.privateInvoke(StubInvocationHandlerImpl.java:186)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:152)
      at
      com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(BCELStubBase.java:225)
      at
      com.sun.enterprise.naming._SerialContextProvider_DynamicStub.lookup(com/sun/enterprise/naming/_SerialContextProvider_DynamicStub.java)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:409)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at ch.parametrix.test.GlassFish.callHelloWorld(GlassFish.java:24)
      at ch.parametrix.test.Main$1.actionPerformed(Main.java:23)
      at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
      at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
      at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
      at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
      at
      javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
      at java.awt.Component.processMouseEvent(Component.java:6216)
      at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
      at java.awt.Component.processEvent(Component.java:5981)
      at java.awt.Container.processEvent(Container.java:2041)
      at java.awt.Component.dispatchEventImpl(Component.java:4583)
      at java.awt.Container.dispatchEventImpl(Container.java:2099)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
      at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
      at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
      at java.awt.Container.dispatchEventImpl(Container.java:2085)
      at java.awt.Window.dispatchEventImpl(Window.java:2475)
      at java.awt.Component.dispatchEvent(Component.java:4413)
      at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
      at
      java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
      at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
      at
      java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
      at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
      at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
      Caused by: java.lang.RuntimeException: java.net.ConnectException: Connection
      refused: connect
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:347)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:244)
      ... 46 more
      Caused by: java.net.ConnectException: Connection refused: connect
      at sun.nio.ch.Net.connect(Native Method)
      at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:507)
      at com.sun.corba.ee.impl.orbutil.ORBUtility.openSocketChannel(ORBUtility.java:105)
      at
      com.sun.enterprise.iiop.IIOPSSLSocketFactory.createSocket(IIOPSSLSocketFactory.java:332)
      ... 47 more
      19.10.2009 16:00:15
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl <init>
      WARNUNG: "IOP00410201: (COMM_FAILURE) Connection failure: socketType:
      IIOP_CLEAR_TEXT; hostname: 192.168.73.114; port: 3820"
      org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2690)
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.connectFailure(ORBUtilSystemException.java:2711)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:261)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelConnectionImpl.<init>(SocketOrChannelConnectionImpl.java:274)
      at
      com.sun.corba.ee.impl.transport.SocketOrChannelContactInfoImpl.createConnection(SocketOrChannelContactInfoImpl.java:130)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientRequestDispatcherImpl.beginRequest(CorbaClientRequestDispatcherImpl.java:192)
      at
      com.sun.corba.ee.impl.protocol.CorbaClientDelegateImpl.request(CorbaClientDelegateImpl.java:181)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.privateInvoke(StubInvocationHandlerImpl.java:186)
      at
      com.sun.corba.ee.impl.presentation.rmi.StubInvocationHandlerImpl.invoke(StubInvocationHandlerImpl.java:152)
      at
      com.sun.corba.ee.impl.presentation.rmi.bcel.BCELStubBase.invoke(BCELStubBase.java:225)
      at
      com.sun.enterprise.naming._SerialContextProvider_DynamicStub.lookup(com/sun/enterprise/naming/_SerialContextProvider_DynamicStub.java)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:409)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at com.sun.enterprise.naming.SerialContext.lookup(SerialContext.java:436)
      at javax.naming.InitialContext.lookup(InitialContext.java:392)
      at ch.parametrix.test.GlassFish.callHelloWorld(GlassFish.java:24)

      Here are the source code lines that cause the endless recursion:

      //temp fix for 6320008
      //this should be removed once we change the transient NS implementation to
      persistent
      if (ex instanceof java.rmi.MarshalException &&
      ex.getCause() instanceof org.omg.CORBA.COMM_FAILURE) {
      provider = null;
      _logger.fine("Resetting provider to NULL. Will get new obj ref for provider
      since previous obj ref was stale...");
      return lookup(name);

      Here is our client programm we used to reproduce the bug:

      import javax.naming.InitialContext;
      import javax.swing.JButton;
      import javax.swing.JFrame;

      import ch.parametrix.login.srv.api.ILoginService;
      import ch.parametrix.login.srv.api.SystemMessage;

      public class Main
      {
      public static void main(String[] args)
      {
      JFrame frame = new JFrame("Glassfish Test");

      JButton button = new JButton("call Hello world");
      button.addActionListener(new ActionListener()
      {
      public void actionPerformed(ActionEvent e)
      {
      long time1 = System.currentTimeMillis();
      try
      {
      Properties properties = new Properties();

      properties.setProperty("org.omg.CORBA.ORBInitialHost",
      System.getProperty("ch.parametrix.server.host", "localhost"));
      properties.setProperty("org.omg.CORBA.ORBInitialPort",
      System.getProperty("ch.parametrix.server.port", "3700"));

      try

      { InitialContext context = new InitialContext(properties); ILoginService srv = (IHelloEjb) context.lookup("ejb/HelloWorldEJB"); String message = srv.sayHello("hello"); if (message != null) System.out.println("" + message); }

      catch (Exception e2)

      { e2.printStackTrace(); throw new RuntimeException(e2); }

      }
      finally

      { long duration = System.currentTimeMillis() - time1; duration /= 1000; System.out.println("duration : " + duration); }

      }
      });

      frame.add(button);
      frame.pack();
      frame.setVisible(true);
      }
      }

        Issue Links

          Activity

          ksak added a comment -

          Changing to P3 and marking v3_exclude. Not a must-fix for V3 FCS. Will address in V3.1.

          marina vatkina added a comment -

          Will need to come up with a way to set a limit on the number of retries

          Ken Cavanaugh added a comment -

          Fixed in GF trunk in rev 40424.

          I modified the SerialContext.lookup code to recurse at most 5 times
          before throwing a COMM_FAILURE exception. Note that this bug normally
          only shows up in the face of another bug, although misconfiguring the
          host/port on an app client might trigger similar behaviour.


            People

            • Assignee:
              ksak
              Reporter:
              bursascha
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: