Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: jsf
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Macintosh

    • Issuezilla Id:
      10,467

      Description

      Glassfish v3 b67

      JSF 2.0 cannot be deployed to Glassfish v3b67 with NetBeans 6.8m2. War-only deployment works
      perfectly.

      Error message:

      SEVERE: Exception while loading the app
      java.lang.Exception: java.lang.IllegalStateException: ContainerBase.addChild: start:
      org.apache.catalina.LifecycleException: org.apache.catalina.LifecycleException:
      java.lang.IllegalStateException: Application was not properly initialized at startup, could not find
      Factory: javax.faces.context.FacesContextFactory
      at com.sun.enterprise.web.WebApplication.start(WebApplication.java:122)
      at org.glassfish.internal.data.EngineRef.start(EngineRef.java:126)
      at org.glassfish.internal.data.ModuleInfo.start(ModuleInfo.java:240)
      at org.glassfish.internal.data.ApplicationInfo.start(ApplicationInfo.java:214)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:307)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:169)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:275)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:305)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:320)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1154)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:83)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.ja
      va:1213)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.ja
      va:1202)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:354)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:193)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:166)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:241)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:753)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:661)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:914)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:166)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at com.sun.grizzly.util.FixedThreadPool$BasicWorker.dowork(FixedThreadPool.java:379)
      at com.sun.grizzly.util.FixedThreadPool$BasicWorker.run(FixedThreadPool.java:360)
      at java.lang.Thread.run(Thread.java:637)

        Activity

        abien added a comment -

        Created an attachment (id=3580)
        NB Project with EAR

        bernd_zedv added a comment -
            • Issue 10467 has been confirmed by votes. ***
        Ryan Lubke added a comment -

        This isn't a JSF issue.

        This looks to be a duplicate of issue 10203. The solution there was to not
        package the EJB jar with the web application. Indeed, when I look at the
        application's configuration, the web application includes the EJB jar.
        Unchecking this option allows the application to deploy.

            • This issue has been marked as a duplicate of 10203 ***

          People

          • Assignee:
            Ryan Lubke
            Reporter:
            abien
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: