glassfish
  1. glassfish
  2. GLASSFISH-10590

ql: failed to deploy numberguess.war on AIX

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: 3.1.1
    • Component/s: cdi, web_container
    • Labels:
      None
    • Environment:

      Operating System: AIX
      Platform: All

      Description

      ql: failed to deploy numberguess.war on AIX

      web.zip from
      http://hudson.glassfish.org/job/gf-trunk-build-continuous/
      #3015, Oct. 26, 2009, 100% pass on Solaris x86.

      On AIX 6.1 with JDK1.6:
      deploy-v3-impl:
      [echo] deploying numberguess.war
      deploy-v3-impl-unix:
      [exec] com.sun.enterprise.admin.cli.CommandException: remote failure:
      Exception while loading the app : javax.validation.ValidationException:
      Unable to find a default provider
      [exec] Command deploy failed.
      [exec] Result: 1

      [#|2009-10-26T18:05:49.326-0500|INFO|glassfish|org.jboss.weld.bootstrap.WeldBootstrap|
      _ThreadID=13;_ThreadName=Thread-3;|Weld 1.0.0-CR1-SP1|#]

      [#|2009-10-26T18:05:49.371-0500|SEVERE|glassfish|javax.enterprise.system.core.org.glassfish.internal.data|
      _ThreadID=13;_ThreadName=Thread-3;|
      Exception while invoking class org.glassfish.weld.WeldDeployer load method
      javax.validation.ValidationException: Unable to find a default provider
      at javax.validation.Validation$GenericBootstrapImpl.configure(Validation.java:264)
      at javax.validation.Validation.buildDefaultValidatorFactory(Validation.java:111)
      at
      org.glassfish.weld.services.ValidationServicesImpl.<init>(ValidationServicesImpl.java:49)
      at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:232)
      at org.glassfish.weld.WeldDeployer.load(WeldDeployer.java:86)
      at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:165)
      at org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:211)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:316)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.java:169)
      at org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:272)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:305)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:320)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1159)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:83)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1218)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1207)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:362)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:201)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:166)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:241)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:789)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:697)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:952)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:166)
      at
      com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:735)

      #]

        Issue Links

          Activity

          jluehe added a comment -

          ...

          kumara added a comment -

          AIX support being deferred to v3.1.

          rogerk added a comment -

          Can you please try the latest numberguess app?

          scatari added a comment -

          Targeting fix for 3.1.1.

          rogerk added a comment -

          This seems related to:

          http://java.net/jira/browse/GLASSFISH-10568

          In which case, it could be an IBM JDK issue...

          scatari added a comment -

          Reopening for 3.1.1 as AIX is a supported platform for this release.

          Sivakumar Thyagarajan added a comment -

          This issue appears to be a duplicate of GLASSFISH-16364, and is due to the non-availability of services specified through the ServiceProvider mechanism in IBM JDK. In this specific case, it is the ValidationFactory service. Marking this as a duplicate.

          Sivakumar Thyagarajan added a comment -

          Duplicate of GLASSFISH-16364


            People

            • Assignee:
              Sivakumar Thyagarajan
              Reporter:
              sherryshen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: