glassfish
  1. glassfish
  2. GLASSFISH-10604

Comet Sample Application Tic Tac Toe not working on GF v3

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      Operating System: Mac OS X
      Platform: Macintosh

    • Issuezilla Id:
      10,604

      Description

      The tic tac to Comet application used to work on GF v3 prelude now is not
      working on the GF v3 anymore.

        Issue Links

          Activity

          msreddy added a comment -

          I think you are referring to comet sample application from
          https://grizzly.dev.java.net/ as this is not part of glassfish-sample applications.

          Also it would help if you provide the steps in detail to reproduce the bug and
          attach server.log, stacktrace if any.

          Transferring the bug to grizzly in absence of any other specific component.

          msreddy added a comment -

          assigned to grizzly

          jfarcand added a comment -

          Doris, can you attach the war file and the source?

          jfarcand added a comment -

          The issue is caused by the application itself, which do some I/O operations
          after the response has been resumed, corrupting the Response object.

          Sending comet/src/main/java/com/sun/grizzly/comet/CometContext.java
          Transmitting file data .
          Committed revision 3861.


            People

            • Assignee:
              jfarcand
              Reporter:
              doris
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: