glassfish
  1. glassfish
  2. GLASSFISH-10693

[OpenInstaller, RN] [UB] Installer -l option which specify the log directory does not work

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: docs
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      10,693

      Description

      Build: GFv3 b70 / SDK b26
      OS: Windows 2008

      The -a, -s, -n options are working but the -l option is not. The log files are
      placed in %TEMP% directory even if "-l C:\mylog" directory is specified.

      (Related to issue 8399. File as a separate issue per developer's request and
      will close 8399.)

        Activity

        scatari added a comment -

        I couldn't reproduce this on B71. I ran the installer with -l option pointing to
        an existing directory like this ".\latest-web-windows.exe -l c:\mylog" and I
        could see the log files.

        C:\mylog>dir
        Volume in drive C has no label.
        Volume Serial Number is 290E-14EF

        Directory of C:\mylog

        11/05/2009 12:39 PM <DIR> .
        11/05/2009 12:39 PM <DIR> ..
        11/05/2009 12:44 PM 302,029 2009-11-05-12-44-install.log
        11/05/2009 12:44 PM 3,975 2009-11-05-12-44-install-summary.html
        2 File(s) 306,004 bytes
        2 Dir(s) 2,651,160,576 bytes free

        Please pass on the command line used.

        nluu added a comment -

        I used the command:

        <installer> -a C:\mystatefile -s -l C:\mylog

        and

        uninstall.exe -l C:\mylog

        scatari added a comment -

        This is an open installer bug, I just confirmed it. We will have to document
        this given that OI can't be fixed now. Please document the following (RN)

        "Option -l to relocate installer log files will be ignored when used with
        options -a and -s and the log files are created in the default location".

        Paul Davies added a comment -

        Added [UB] to summary to denote that the issue affects documentation that is not
        bundled with the software.

        Reassigned to user grisdal

        kumara added a comment -

        Release note has been added.


          People

          • Assignee:
            Gail Risdal
            Reporter:
            nluu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: