Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v2.1.1
    • Fix Version/s: v2.1.2
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      10,751
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      Note that I've picked this up from source, please invalidate if this source is
      not in use anymore.

      Some of the getter methods in StatefulSessionStoreStatsImpl seem to return a
      different variable than what their method names would let you believe they
      should return:

      • getPassivationErrorCount() updates passivationErrorCount but returns
        passivationSuccessCount.
      • getPassivationCount() updates passivationCount but returns
        passivationSuccessCount.

        Activity

        marina vatkina added a comment -

        These statistics are not working in v2.x (and prior). See issue
        https://glassfish.dev.java.net/issues/show_bug.cgi?id=10109

        In v3 this code is not used because monitoring is done differently. It will be
        removed when all monitoring related stuff is sorted out.

            • This issue has been marked as a duplicate of 10109 ***

          People

          • Assignee:
            ksak
            Reporter:
            Dies Koper
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: