glassfish
  1. glassfish
  2. GLASSFISH-10755

[UB] Issues occurs after installing .zip distribution on Vista with UAC turned on.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: docs
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      10,755

      Description

      V3
      build: glassfish-v3-web-b71-11_01_2009.zip (nightly) and Hudson build

      Can not bring up Admingui,when install using zip file on windows vista.R
      eproduced with both nightly, Hudson builds

      How to reproduce:

      • Unzip zip file (ex: glassfish-v3-web-b71-11_01_2009.zip (nightly)
      • Start server
      • Try to bring up admingui.

      Server.log:
      attached

      Note: When install with GUI insatller it works fine.

      1. server.log
        25 kB
        sujatha_chintalapati

        Activity

        sujatha_chintalapati added a comment -

        Created an attachment (id=3727)
        server.log

        Anissa Lam added a comment -

        Sujatha,
        I remember that when i was in your office doing this, it is not just admingui
        has the problem.
        We cannot deploy other war file either.
        Am i correct ? There were so many problem with the machine that i forgot what
        we have tried.

        Can you perform this one more time:

        • unzip the zip file
        • start server
        • deploy a war file and run it.

        thanks

        Anissa Lam added a comment -

        Sujatha is running on Window Vista, this seems to be issue with window vista
        only, since she tried nightly build and also tried the latest successful builds
        from Hudson with same issue. I tried zip file of the same version and cannot
        reproduce this on my Mac.

        Looking at the log, the error is coming from the web container:
        [#|2009-11-02T19:07:17.797-0800|SEVERE|glassfishv3.0|javax.enterprise.system.container.web.com.sun.enterprise.glassfish.web|_ThreadID=24;_ThreadName=Thread-1;|ParseError
        at [row,col]:[40,10]
        Message: DOCTYPE is disallowed when the feature
        "http://apache.org/xml/features/disallow-doctype-decl" set to true.|#]

        Caused by: java.lang.ClassNotFoundException:
        com.sun.webui.jsf.faces.UIComponentELResolver

        and
        [#|2009-11-02T19:07:22.110-0800|SEVERE|glassfishv3.0|null|_ThreadID=24;_ThreadName=Thread-1;|Exception
        while loading the app : java.lang.Exception: java.lang.IllegalStateException:
        ContainerBase.addChild: start: org.apache.catalina.LifecycleException:
        com.sun.faces.config.ConfigurationException: CONFIGURATION FAILED!
        com.sun.webui.jsf.faces.UIComponentELResolver|#]

        I am not sure if this should go to packaging or web container.
        Since this exception comes from web container, lets start there.

        sujatha_chintalapati added a comment -

        Anissa,
        Yes, it is not just admingui problem.We cannot deploy other war file either.
        I have tried again on 11/03 build and reproduced the problem on vista machine..

        Here are the steps:

        • unzip the zip file
        • start server
        • deploy a war file from command line. Deployment failes with the following
          message.

        c:\..\glassfishv3\bin>asadmin deploy
        c:\samples\samples\webapps\apps\simple\webapps-simple.war
        Authentication failed with password from login store: C:\.asadminpa
        ss
        Enter admin password for user "admin">
        Authentication failed for user: admin
        (Usually, this means invalid user name and/or password)
        Command deploy failed.

        yifeng1 added a comment -

        Authentication failed with password from login store: C:\.asadminpass

        Sujatha, could you delete this file and try again? thanks

        Snjezana Sevo-Zenzerovic added a comment -

        I am unable to reproduce this with glassfish-v3-web-b71-11_01_2009.zip on
        Windows XP - Admin GUI works just fine.

        Note that the default domain of the zip distribution use "admin" username and
        empty password. Do you have .asadminpass on the system which defines something
        other than this?

        sujatha_chintalapati added a comment -

        Yifeng,
        I have removed .asadminpass file and tried agian. But no luck, running in to
        following exceptions.

        c:\..\glassfishv3\bin>asadmin deploy c:\samples\sample
        s\webapps\apps\simple\webapps-simple.war
        com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while l
        oading the app : java.lang.Exception: java.lang.IllegalStateException: Container
        Base.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalA
        rgumentException: java.lang.ClassNotFoundException: samples.webapps.simple.servl
        et.listeners.ContextListener

        Command deploy failed.

        sujatha_chintalapati added a comment -

        Hi Snjezana,
        This is the problem with windows vista.

        I got same exceptions even with password empty.
        c:\..\glassfishv3\bin>asadmin deploy c:\samples\sample
        s\webapps\apps\simple\webapps-simple.war
        Authentication failed with password from login store: C:\.asadminpa
        ss
        Enter admin password for user "admin">
        com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while l
        oading the app : java.lang.Exception: java.lang.IllegalStateException: Container
        Base.addChild: start: org.apache.catalina.LifecycleException: java.lang.IllegalA
        rgumentException: java.lang.ClassNotFoundException: samples.webapps.simple.servl
        et.listeners.ContextListener

        Command deploy failed.

        Snjezana Sevo-Zenzerovic added a comment -

        Sujatha, which unzip utility did you use to unzip the distribution?

        jluehe added a comment -

        I think the exception message is pretty clear:

        java.lang.ClassNotFoundException:
        samples.webapps.simple.servlet.listeners.ContextListener

        Is this class bundled with the samples app?

        sujatha_chintalapati added a comment -

        mark issue as BLOCKING since it reroducible on multiple vista machines.

        Snjezana Sevo-Zenzerovic added a comment -

        Please answer the question above. Also, did you by any chance install this under
        "Program Files" directory and is UAC enabled on those machines?

        Anissa Lam added a comment -

        So far,
        Nolan, Davis, and Sankar is able to unzip the .zip distribution and launch GUI.
        The long startup time will be addressed in issue# 10499.

        This issue only happens on Sujatha's machine, and thanks to Snjezana, it is
        resolved.
        The Vista machine that Sujatha has is running with UAC enabled. Thats the first
        question that Snjezana asked

        Once Snjezana helped Sujatha disabled UAC, reboot system, everything works as
        expected.

        Since this is really not a BLOCKING issue, i have removed that word.

        I don't know how Snjezana wants to handle this bug, should it be documented in
        release note to tell user NOT to enable UAC ?
        I am transferring this to packaging and Snjezana can decide.

        thanks everyone for helping out with this issue !!

        Snjezana Sevo-Zenzerovic added a comment -

        I was under impression that the requirement to disable UAC was already
        documented somewhere in Preview documentation, but I can't find it in
        Installation Guide, Troubleshooting Guide or Release Notes. So, I am
        transferring this issue to "docs" since we need to document that some features
        do not work well on Windows Vista with enabled UAC.

        Snjezana Sevo-Zenzerovic added a comment -

        ...

        judytangs added a comment -

        We should also doc this in trouble shooting guide if it is not there yet. Could
        we do it ?

        Paul Davies added a comment -

        Reassigned to grisdal

        Anissa Lam added a comment -

        Note that Admin Console is not the only issue. I have just changed the summary
        to better reflect the problem.

        kumara added a comment -

        Unbundled docs issue, lowering to P3.

        kumara added a comment -

        Added to release notes.

        Scott Fordin added a comment -

        Is not enough to start GF with the Vista "Run as Administrator" option? I
        always start GlassFish this way, and have no difficulties with Admin Console,
        deployments, or anything else. I'm concerned that encouraging users to totally
        disable UAC will bang up against corporate restrictions in many organizations.


          People

          • Assignee:
            Gail Risdal
            Reporter:
            sujatha_chintalapati
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: