glassfish
  1. glassfish
  2. GLASSFISH-10764

need to check the minimum java version at build stage

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 4.0
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      10,764

      Description

      When installing GlassFish from a jar file, it would be good to check the java
      version at the build stage.

      1. java -Xmx256m -jar glassfish-installer-ml.jar
      2. cd glassfish
      3. chmod -R +x lib/ant/bin
      4. lib/ant/bin/ant -f setup.xml
        => need to check here is the java the user is using meets GlassFish requirements.

      Java 1.6 is needed from GlassFish3, and if Java 1.5 is used, it throws some
      unhelpful error.

        Activity

        Hide
        Tom Mueller added a comment -

        This is fixed in 4.0.

        Show
        Tom Mueller added a comment - This is fixed in 4.0.
        Hide
        Tom Mueller added a comment -

        Bulk update to change fix version to "not determined" for all issues still open but with a fix version for a released version.

        Show
        Tom Mueller added a comment - Bulk update to change fix version to "not determined" for all issues still open but with a fix version for a released version.
        Hide
        pierrot added a comment -

        Wanted to file this as an RFE.

        Show
        pierrot added a comment - Wanted to file this as an RFE.

          People

          • Assignee:
            Tom Mueller
            Reporter:
            pierrot
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: