Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: v2.1.1
    • Fix Version/s: 3.1.1, 3.1.2
    • Component/s: naming
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: All

    • Issuezilla Id:
      10,926
    • Status Whiteboard:

      v3_exclude, 3.1-exclude

      Show
      v3_exclude, 3.1-exclude
    • Tags:

      Description

      OS: AIX machine
      build: V2.1.1
      JDK version: IBM jdk1.6 + IBM patch for issue 6836 fix

      aixas5(aroot):as911_ws/appserver-sqe -> /usr/java6/bin/java -version
      java version "1.6.0"
      Java(TM) SE Runtime Environment (build pap3260sr5-20090529_04(SR5))
      IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 AIX ppc-32
      jvmap3260sr5-20090519_35743 (JIT enabled, AOT enabled)
      J9VM - 20090519_035743_bHdSMr
      JIT - r9_20090518_2017
      GC - 20090417_AA)
      JCL - 20090529_01

      After applying the IBM patch, we no longer saw errors that reported in issue
      6836. However, all the test cases using ejb lookup in the SQE core modules are
      still failed. The issue blocked Core testing on AIX.

      Steps to reproduce the bug:
      1. Install V2.1.1. start domain
      2. Checkout SQE workspace:
      cvs co -r SJSAS911_FCS_BRANCH appserver-sqe/bootstrap.xml
      (CVSROOT: :pserver:<user>@redcvs.red.iplanet.com:/m/jws)
      cd appserver-sqe
      ant -f bootstrap.xml -Dtag=SJSAS911_FCS_BRANCH co-security
      3.set env. variables
      S1AS_HOME <AS install dir>
      SPS_HOME <appserver-sqe>
      ANT_HOME <ant 1.6.5>
      JAVA_HOME <jdk1.6.0_16>
      4. open file appserver-sqe/pe/config.properties, update right path and ports to
      match your AS installation data (for example: admin password, http port, admin
      port...)
      5. cd appserver-sqe/pe/security/authoriz/methodperms, run "ant build setup
      deploy run", the test failed with the following error:
      runclient-common:
      [echo] Executing appclient at
      /export/homer/as911_ws/appserver-sqe/pe/security/authoriz/methodperms
      [echo] WS HOME appserver-sqe
      [echo] -->EJB method permissions!javax.naming.NameNotFoundException:
      ??MyMethodPerm not found
      [echo] at
      ?com.sun.enterprise.naming.TransientContext.?doLookup(?TransientContext.java:216)
      [echo] at
      ?com.sun.enterprise.naming.TransientContext.?lookup(?TransientContext.java:188)
      [echo] at
      ?com.sun.enterprise.naming.SerialContextProviderImpl.?lookup(?SerialContextProviderImpl.java:74)
      [echo] at
      ?com.sun.enterprise.naming.RemoteSerialContextProviderImpl.?lookup(?RemoteSerialContextProviderImpl.java:129)
      [echo] at ?sun.reflect.NativeMethodAccessorImpl.?invoke0(Native Method)
      [echo] at
      ?sun.reflect.NativeMethodAccessorImpl.?invoke(?NativeMethodAccessorImpl.java:39)
      [echo] at
      ?sun.reflect.DelegatingMethodAccessorImpl.?invoke(?DelegatingMethodAccessorImpl.java:37)
      [echo] at ?java.lang.reflect.Method.?invoke(?Method.java:599)
      [echo] at
      ?com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie.?_invoke(?ReflectiveTie.java:154)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatchToServant(?CorbaServerRequestDispatcherImpl.java:687)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatch(?CorbaServerRequestDispatcherImpl.java:227)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequestRequest(?CorbaMessageMediatorImpl.java:1846)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:1706)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleInput(?CorbaMessageMediatorImpl.java:1088)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.?callback(?RequestMessage_1_2.java:223)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:806)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?dispatch(?CorbaMessageMediatorImpl.java:563)
      [echo] at
      ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?doWork(?CorbaMessageMediatorImpl.java:2567)
      [echo] at
      ?com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.?run(?ThreadPoolImpl.java:555)
      [echo] Calling authorized method - authorizedMethod
      [echo] java.lang.NullPointerException
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.doTest(MethodPermClient.java:69)
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.main(MethodPermClient.java:28)
      [echo] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [echo] at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [echo] at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [echo] at java.lang.reflect.Method.invoke(Method.java:599)
      [echo] at
      com.sun.enterprise.util.Utility.invokeApplicationMain(Utility.java:266)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:450)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:260)
      [echo] at com.sun.enterprise.appclient.Main.main(Main.java:200)
      [echo] Test Failed
      [echo] Calling unauthorized method - sayGoodBye
      [echo] Calling unauthorized method - unauthorizedMethod
      [echo] Nov 9, 2009 4:42:19 PM
      com.sun.enterprise.appclient.MainWithModuleSupport <init>
      [echo] WARNING: ACC003: Application threw an exception.
      [echo] Throwable occurred: java.lang.NullPointerException
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.doTest(MethodPermClient.java:107)
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.main(MethodPermClient.java:28)
      [echo] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [echo] at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [echo] at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [echo] at java.lang.reflect.Method.invoke(Method.java:599)
      [echo] at
      com.sun.enterprise.util.Utility.invokeApplicationMain(Utility.java:266)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:450)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:260)
      [echo] at com.sun.enterprise.appclient.Main.main(Main.java:200)
      [echo] Exception in thread "main" java.lang.RuntimeException:
      java.lang.reflect.InvocationTargetException
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:462)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:260)
      [echo] at com.sun.enterprise.appclient.Main.main(Main.java:200)
      [echo] Caused by: java.lang.reflect.InvocationTargetException
      [echo] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [echo] at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      [echo] at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [echo] at java.lang.reflect.Method.invoke(Method.java:599)
      [echo] at
      com.sun.enterprise.util.Utility.invokeApplicationMain(Utility.java:266)
      [echo] at
      com.sun.enterprise.appclient.MainWithModuleSupport.<init>(MainWithModuleSupport.java:450)
      [echo] ... 2 more
      [echo] Caused by: java.lang.NullPointerException
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.doTest(MethodPermClient.java:107)
      [echo] at
      com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.main(MethodPermClient.java:28)
      [echo] ... 8 more

      There is no exceptions in server.log (server.log attached)

        Activity

        sonialiu added a comment -

        Created an attachment (id=3834)
        server.log

        Ken Cavanaugh added a comment -

        Why do you think this is an ORB bug? The ORB only appears to be the
        messenger here. What is the NPE at the bottom of the stack in
        com.sun.s1peqe.security.authoriz.methodperms.MethodPermClient.doTest?
        Does this mean that something under test returned an unexpected null
        pointer?

        The only ORB code here is simply delivering an incoming request to
        GlassFish naming, which is not part of the ORB. I'll re-assign this to
        naming for lack of a better category.

        sonialiu added a comment -

        I was not sure which category i should choose for the bug. Since the client
        outputs have a common exception "javax.naming.NameNotFoundException" and it
        pointed to "com.sun.corba.ee.impl....", so I thought I should choose ORB
        category. Appreciate if you could let me know which subcomponent this bug
        belongs to. I will reassign it. Thanks.

        Here are more client logs from deployment and ejb test modules:

        client side log from deployment test module:------------------

        runclient-common:
        [echo] Executing appclient at
        /export/homer/as911_ws/appserver-sqe/pe/deployment/stateless/helloworld
        [echo] WS HOME appserver-sqe
        Client: caught throwable
        javax.naming.NameNotFoundException: ??helloworld not found
        at
        ?com.sun.enterprise.naming.TransientContext.?doLookup(?TransientContext.java:216)
        at ?com.sun.enterprise.naming.TransientContext.?lookup(?TransientContext.java:188)
        at
        ?com.sun.enterprise.naming.SerialContextProviderImpl.?lookup(?SerialContextProviderImpl.java:74)
        at
        ?com.sun.enterprise.naming.RemoteSerialContextProviderImpl.?lookup(?RemoteSerialContextProviderImpl.java:129)
        at ?sun.reflect.GeneratedMethodAccessor94.?invoke(Unknown Source)
        at
        ?sun.reflect.DelegatingMethodAccessorImpl.?invoke(?DelegatingMethodAccessorImpl.java:37)
        at ?java.lang.reflect.Method.?invoke(?Method.java:599)
        at
        ?com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie.?_invoke(?ReflectiveTie.java:154)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatchToServant(?CorbaServerRequestDispatcherImpl.java:687)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatch(?CorbaServerRequestDispatcherImpl.java:227)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequestRequest(?CorbaMessageMediatorImpl.java:1846)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:1706)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleInput(?CorbaMessageMediatorImpl.java:1088)
        at
        ?com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.?callback(?RequestMessage_1_2.java:223)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:806)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?dispatch(?CorbaMessageMediatorImpl.java:563)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?doWork(?CorbaMessageMediatorImpl.java:2567)
        at
        ?com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.?run(?ThreadPoolImpl.java:555)

        ---- client side log from ejb test module -------------------
        runclient-common:
        [echo] Executing appclient at
        /export/homer/as911_ws/appserver-sqe/pe/ejb/stateful/passivate
        [echo] WS HOME appserver-sqe
        Test Execution Starts---------->
        Looking up SFSB0
        Lookup of beans failed
        javax.naming.NameNotFoundException: ??MySessionTest not found
        at
        ?com.sun.enterprise.naming.TransientContext.?doLookup(?TransientContext.java:216)
        at ?com.sun.enterprise.naming.TransientContext.?lookup(?TransientContext.java:188)
        at
        ?com.sun.enterprise.naming.SerialContextProviderImpl.?lookup(?SerialContextProviderImpl.java:74)
        at
        ?com.sun.enterprise.naming.RemoteSerialContextProviderImpl.?lookup(?RemoteSerialContextProviderImpl.java:129)
        at ?sun.reflect.GeneratedMethodAccessor94.?invoke(Unknown Source)
        at
        ?sun.reflect.DelegatingMethodAccessorImpl.?invoke(?DelegatingMethodAccessorImpl.java:37)
        at ?java.lang.reflect.Method.?invoke(?Method.java:599)
        at
        ?com.sun.corba.ee.impl.presentation.rmi.ReflectiveTie.?_invoke(?ReflectiveTie.java:154)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatchToServant(?CorbaServerRequestDispatcherImpl.java:687)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaServerRequestDispatcherImpl.?dispatch(?CorbaServerRequestDispatcherImpl.java:227)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequestRequest(?CorbaMessageMediatorImpl.java:1846)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:1706)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleInput(?CorbaMessageMediatorImpl.java:1088)
        at
        ?com.sun.corba.ee.impl.protocol.giopmsgheaders.RequestMessage_1_2.?callback(?RequestMessage_1_2.java:223)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?handleRequest(?CorbaMessageMediatorImpl.java:806)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?dispatch(?CorbaMessageMediatorImpl.java:563)
        at
        ?com.sun.corba.ee.impl.protocol.CorbaMessageMediatorImpl.?doWork(?CorbaMessageMediatorImpl.java:2567)
        at
        ?com.sun.corba.ee.impl.orbutil.threadpool.ThreadPoolImpl$WorkerThread.?run(?ThreadPoolImpl.java:555)
        Test didn't run

        sherryshen added a comment -

        change version from v3 to v2.1.1.

        sonialiu added a comment -

        correct product version. It should be v2.1.1.

        kumara added a comment -

        Excluding from v3, AIX is not supported for v3.

        Nazrul added a comment -

        Setting target milestone to 3.1

        Cheng Fang added a comment -

        Support for AIX platform will be added post 3.1 release.

        Cheng Fang added a comment -

        Confirmed with Sonia and Sherry that this issue is no longer present in 3.1.1 testing.


          People

          • Assignee:
            Cheng Fang
            Reporter:
            sonialiu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: