glassfish
  1. glassfish
  2. GLASSFISH-11023

SDK6:JSF:scrumtoys:red error appears "ConstraintPayload"

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: sample_apps
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      11,023

      Description

      -The red icon only appear when the project open on the window machine,
      "javax.validation.ConstraintPayload" class is missing. Please see the attached
      screen shot for the problem image in details.
      -This seems a regression problem

      Steps To Reproduce:
      1. Install NB IDE, nightly 11/09/2009 build
      2. Install the SDK b72 build on winXP machine
      3. Start the IDE -> open the web/jsf/scrumtoys project

        Activity

        Ed Burns added a comment -

        The class was renamed because the JSR-303 EG felt the new name was better, if
        that's what you're asking.

        I have called the reporter asking for more detail on how to get the samples. In
        the meantime, marking INVALID because it works in the latest source.

        ne110415 added a comment -

        I was trying to highlight the fact that there is a mismatch in BV versions here.
        Looks like NB has the latest bv jar and we are a step back...

        Reason I know this is when I was tryign to add a custom validator (this class is
        used there), I had used Payload.java. And it worked fine till Jane reverted the
        BV version. At that point compilation failed. So I changed the classname to
        ConstraintPayload.java

        What is more confusing is that all along (that is before and after BV was
        updated), per Grizzly team, their validators (which were using ConstraintPayload
        from older BV versions) were working fine too. Worst it can indicate to is that
        two versions of the same artifact are being used within GF. Or perhaps there is
        some other explanation. (But this is a separate topic to discuss. Grizzly needs
        to compile with newer BV versions, apparently that step is missing. So when new
        BV itnergation is done, hk2's pom changes, but not Grizzly's)

        Ed Burns added a comment -
            • Issue 11027 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Ed Burns
            Reporter:
            davisn
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: