glassfish
  1. glassfish
  2. GLASSFISH-11032

@PreDestroy method is called twice in stateless EJB

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 9.1.1
    • Fix Version/s: 3.1
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      11,032
    • Status Whiteboard:

      v3_exclude

      Show
      v3_exclude

      Description

      I use GF v2.1 (9.1.1) (build b60e-fcs) with Netbeans IDE 6.5.1 (Build
      200905151554).
      I created in Netbeans EnterpriseApplication project with EJB annotated as
      @WebService(), deployed, called some test webservice method and then undeployed
      application. @PostConstruct method printed in log just ones, but @PreDestroy
      printed twice.

        Activity

        sergipu added a comment -

        Created an attachment (id=3902)
        EnterpriseApplication Netbeans project illustrating the bug

        ksak added a comment -

        Could not reproduce on two different stateless @WebService endpoint apps in V3. Marking v3_exclude.

        marina vatkina added a comment -

        not reproducible


          People

          • Assignee:
            ksak
            Reporter:
            sergipu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: