glassfish
  1. glassfish
  2. GLASSFISH-11342

Access log formatting doesn't take effect

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: V3
    • Fix Version/s: V3
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      11,342

      Description

      I modified the access log format via the admin console to the following (the
      common log format):
      %client.name% - %auth-user-name% [%datetime%] "%request%" %status% %response.length%

      Yet the output in the log file is still formatted with the default log format:
      "0:0:0:0:0:0:0:1%0" "NULL-AUTH-USER" "18/Dec/2009:09:36:36 -0800" "GET /
      HTTP/1.1" 200 5212
      "0:0:0:0:0:0:0:1%0" "NULL-AUTH-USER" "18/Dec/2009:09:36:36 -0800" "GET
      /favicon.ico HTTP/1.1" 404 970
      "0:0:0:0:0:0:0:1%0" "NULL-AUTH-USER" "18/Dec/2009:09:36:36 -0800" "GET
      /favicon.ico HTTP/1.1" 404 970

        Activity

        Hide
        jluehe added a comment -

        ...

        Show
        jluehe added a comment - ...
        Hide
        jluehe added a comment -

        Access log pattern elements are delimited by a leading and trailing %. Any
        characters appearing between two access log pattern elements (such as '-' and
        '[' in your example) will be ignored.

        Show
        jluehe added a comment - Access log pattern elements are delimited by a leading and trailing %. Any characters appearing between two access log pattern elements (such as '-' and '[' in your example) will be ignored.

          People

          • Assignee:
            jluehe
            Reporter:
            iminar
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: