glassfish
  1. glassfish
  2. GLASSFISH-1139

Cascade doesn't work when merging managed entity

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.1pe_dev
    • Component/s: entity-persistence
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,139

      Description

      Suppose entity A has its relationships set to cascade=MERGE. If an instance
      of A is managed, and then merged in the same transaction, then the merge will
      not be cascaded down to the related objects.

      For example:

      tx starts
      query for A
      a.addB(new B());
      em.merge(a);
      tx commit

      This will not cause the new B to be persisted.

        Activity

        ijuma added a comment -

        Adding myself to cc list.

        tware added a comment -

        Created an attachment (id=484)
        diff file for fix

        mf125085 added a comment -
            • Issue 1022 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            marina vatkina
            Reporter:
            mkeith
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: