glassfish
  1. glassfish
  2. GLASSFISH-11420

"Cannot stop module web" on CDI module un-deploy

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1_b34
    • Component/s: other
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      Trying to undeploy a CDI-enabled Web application containing a JSF managed bean defined with @ConversationScoped throws the following exception -

      SEVERE: Cannot stop module web
      java.lang.IllegalStateException: Unknown JCDI-enabled managed bean com.sun.jersey.spi.container.servlet.ServletContainer@50674bf6 of class class
      com.sun.jersey.spi.container.servlet.ServletContainer
      at com.sun.enterprise.container.common.impl.managedbean.ManagedBeanManagerImpl.destroyManagedBean(ManagedBeanManagerImpl.java:533)
      at com.sun.enterprise.container.common.impl.util.InjectionManagerImpl.destroyManagedObject(InjectionManagerImpl.java:339)
      at com.sun.web.server.J2EEInstanceListener.handleAfterEvent(J2EEInstanceListener.java:328)
      at com.sun.web.server.J2EEInstanceListener.instanceEvent(J2EEInstanceListener.java:116)
      at org.apache.catalina.util.InstanceSupport.fireInstanceEvent(InstanceSupport.java:384)
      at org.apache.catalina.core.StandardWrapper.unload(StandardWrapper.java:1745)
      at org.apache.catalina.core.StandardWrapper.stop(StandardWrapper.java:2041)
      at org.apache.catalina.core.StandardContext.stop(StandardContext.java:5371)
      at com.sun.enterprise.web.WebModule.stop(WebModule.java:530)
      at org.apache.catalina.core.ContainerBase.removeChild(ContainerBase.java:1057)
      at com.sun.enterprise.web.WebContainer.unloadWebModule(WebContainer.java:2144)
      at com.sun.enterprise.web.WebContainer.unloadWebModule(WebContainer.java:2092)
      at com.sun.enterprise.web.WebApplication.stop(WebApplication.java:133)
      at org.glassfish.internal.data.EngineRef.stop(EngineRef.java:165)
      at org.glassfish.internal.data.ModuleInfo.stop(ModuleInfo.java:268)
      at org.glassfish.internal.data.ApplicationInfo.stop(ApplicationInfo.java:251)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.unload(ApplicationLifecycle.java:759)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.undeploy(ApplicationLifecycle.java:790)
      at org.glassfish.deployment.admin.UndeployCommand.execute(UndeployCommand.java:184)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:305)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:320)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1176)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:83)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1235)
      at com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRunnerImpl.java:1224)
      at com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:365)
      at com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:204)
      at com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:166)
      at com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)
      at com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:245)
      at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:170)
      at com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
      at com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
      at com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:637)

      To reproduce, simply deploy and undeploy the following:
      http://kenai.com/projects/beginningee6/sources/src/show/tutorial/trunk/Completed/Demo13-CDI

        Activity

        marina vatkina added a comment -

        API added and changed J2EEInstanceListener to use the new API with rev 43958. Assigning to Shing Wai to either mark it as fixed or do any follow up adjustments to the calling side.

        marina vatkina added a comment -

        Added a FINE log message to ManagedBeanManagerImpl at the point where exception was thrown earlier with rev 43962.

        Shing Wai Chan added a comment -

        I have verified that the issue is fixed by deploying and undeploying demo13.war.

        infinitypluszero added a comment -

        This bug is a show stopper in our starter app which is extended from the defauld weld maven archetype. It's using Seam 3 jars (beta/apha) at the moment and seam-solder instead of weld-extensions.

        The app deploys perfectly fine on JBoss AS 6 but has multiple problems including this. Put simply, we're considering using JBoss AS 6 going forward.

        marina vatkina added a comment -

        Do you still see the error? The bug is fixed in 3.1.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            Alexis MP
          • Votes:
            4 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: