glassfish
  1. glassfish
  2. GLASSFISH-11492

NullpointerException in ServletConnectionImpl under load

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: v2.1
    • Fix Version/s: None
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      We have run into a NPE problem pretty consistently when running a JCAPS suite
      health care application. The complete stack trace is copied below. Alexey did
      find a workaround for us which is to disable the port unification by commenting
      out the following property in domain.xml:
      <property name="proxiedProtocols" value="ws/tcp"/>

      But this is not a real solution to the problem (and modifying the domain.xml is
      not an option we can have for the health care product), so we are filing an
      issue for this problem to be properly addressed.

      BTW, since the health product is pretty huge, we cannot attach the sample
      project here. We will be more than happy to provide a test environment and/or
      steps to reproduce the problem upon request.

      Stack trace:
      invocation error on ejb endpoint PIXPDQAuditService at
      /PIXPDQAuditServiceService/PIXPDQAuditService : null
      java.lang.NullPointerException
      at
      com.sun.xml.ws.transport.http.servlet.ServletConnectionImpl.isSecure(ServletConnectionImpl.java:203)
      at com.sun.xml.ws.transport.http.HttpAdapter.decodePacket(HttpAdapter.java:264)
      at com.sun.xml.ws.transport.http.HttpAdapter.access$500(HttpAdapter.java:93)
      at
      com.sun.xml.ws.transport.http.HttpAdapter$HttpToolkit.handle(HttpAdapter.java:432)
      at com.sun.xml.ws.transport.http.HttpAdapter.handle(HttpAdapter.java:244)
      at
      com.sun.xml.ws.transport.http.servlet.ServletAdapter.handle(ServletAdapter.java:135)
      at
      com.sun.enterprise.webservice.Ejb3MessageDispatcher.handlePost(Ejb3MessageDispatcher.java:113)
      at
      com.sun.enterprise.webservice.Ejb3MessageDispatcher.invoke(Ejb3MessageDispatcher.java:87)
      at
      com.sun.enterprise.webservice.EjbWebServiceServlet.dispatchToEjbEndpoint(EjbWebServiceServlet.java:231)
      at
      com.sun.enterprise.webservice.EjbWebServiceServlet.service(EjbWebServiceServlet.java:157)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
      at com.sun.enterprise.web.AdHocContextValve.invoke(AdHocContextValve.java:114)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:87)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:222)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
      at
      org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:166)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:648)
      at org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:593)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:587)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:1093)
      at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:291)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.invokeAdapter(DefaultProcessorTask.java:666)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.doProcess(DefaultProcessorTask.java:597)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultProcessorTask.process(DefaultProcessorTask.java:872)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.executeProcessorTask(DefaultReadTask.java:341)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:263)
      at
      com.sun.enterprise.web.connector.grizzly.DefaultReadTask.doTask(DefaultReadTask.java:214)
      at com.sun.enterprise.web.connector.grizzly.TaskBase.run(TaskBase.java:264)
      at
      com.sun.enterprise.web.connector.grizzly.ssl.SSLWorkerThread.run(SSLWorkerThread.java:106)
      HTTBC-W00758: An exception occured while processing a request message. The
      server sent HTTP status code 500: Internal Server Error...

        Activity

        jluehe added a comment -

        Looks like a Grizzly issue, since disabling port unification for "ws/tcp" fixes
        it. Reassigning ...

        oleksiys added a comment -

        target for ms7

        oleksiys added a comment -

        not v3.x related


          People

          • Assignee:
            oleksiys
            Reporter:
            slweng
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: