glassfish
  1. glassfish
  2. GLASSFISH-11566

NullPointerException encountered and Error message is not clear when deploying a RA application without <resourceadapter-class> tag in ra.xml

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: jca
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: PC

    • Issuezilla Id:
      11,566

      Description

      NullPointerException encountered and Error message is not clear when deploying
      a RA application without <resourceadapter-class> tag in ra.xml.

      When deploying a RA application without <resourceadapter-class> tag in ra.xml,
      the deployment fails with the following error (type - SEVERE) and stack trace.

      From the error message, root cause was not clear.

      Console Output:
      ============================================================================
      C:\sun\glassfishv3\bin>C:/sun/glassfishv3/bin/asadmin deploy --name
      lifecyclev15inboundonlynoclasstag lifecyclev15inboundonlynoclasstag.ear
      com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while
      loading the app : java.lang.RuntimeException: EJB Container initialization error
      Exception while invoking class org.glassfish.ejb.startup.EjbDeployer load
      method : java.lang.RuntimeException: EJB Container initial
      ization error
      ============================================================================

      domain server.log
      ============================================================================
      [#|2010-02-
      12T16:18:19.629+1100|WARNING|glassfishv3.0|javax.enterprise.resource.resourceada
      pter.com.sun.enterprise.connectors.inbound|_ThreadID=30;_ThreadName=Thread-
      1;|Exception during endpoint activation for ra [
      lifecyclev15inboundonlynoclasstag#lifecyclev15inboundonlynoclasstagRA ],
      activationSpecClass [ lifecyclev15inboundonly.ra.InboundActivationSpecImpl ] :
      java.lang.NullPointerException|#]

      [#|2010-02-
      12T16:18:19.644+1100|SEVERE|glassfishv3.0|javax.enterprise.system.container.ejb.
      mdb.com.sun.ejb.containers|_ThreadID=30;_ThreadName=Thread-1;|MDB00017:
      [InboundDebugMessageBean]: Exception in creating message-driven bean container:
      [java.lang.Exception]|#]

      [#|2010-02-
      12T16:18:19.644+1100|SEVERE|glassfishv3.0|javax.enterprise.system.container.ejb.
      mdb.com.sun.ejb.containers|_ThreadID=30;_ThreadName=Thread-
      1;|java.lang.Exception
      java.lang.Exception
      at
      com.sun.enterprise.connectors.inbound.ConnectorMessageBeanClient.setup
      (ConnectorMessageBeanClient.java:225)
      at com.sun.ejb.containers.MessageBeanContainer.<init>
      (MessageBeanContainer.java:200)
      at com.sun.ejb.containers.ContainerFactoryImpl.createContainer
      (ApplicationLifecycle.java:341)

      <snip>

      Caused by: java.lang.Exception
      at
      com.sun.enterprise.connectors.inbound.ConnectorMessageBeanClient.setup
      (ConnectorMessageBeanClient.java:225)
      at com.sun.ejb.containers.MessageBeanContainer.<init>
      (MessageBeanContainer.java:200)
      at com.sun.ejb.containers.ContainerFactoryImpl.createContainer
      (ContainerFactoryImpl.java:116)
      at org.glassfish.ejb.startup.EjbApplication.loadContainers
      (EjbApplication.java:220)
      ... 32 more
      Caused by: java.lang.NullPointerException
      at
      com.sun.enterprise.connectors.inbound.ConnectorMessageBeanClient.setup
      (ConnectorMessageBeanClient.java:217)
      ... 35 more

      #]

      ============================================================================

        Activity

        jajalvipul added a comment -

        Created an attachment (id=4227)
        Ear file to reproduce the issue

        ksak added a comment -

        Exception originating from connector runtime. Reassigning for further analysis.

        Jagadish added a comment -

        When an application (MDB) refers to a resource-adapter that does not have
        <resource-adapter-class>, but inbound artifacts, MDB deployment will fail with
        the message stating :
        <resource-adapter-class> must be specified for the resource-adapter [ RA_NAME ]
        having inbound (<inbound-resource-adapter> or its equivalent annotation) artifacts

        FIX INFORMATION :
        https://glassfish-svn.dev.java.net/servlets/ReadMsg?list=commits&msgNo=18499
        https://glassfish-svn.dev.java.net/servlets/ReadMsg?list=commits&msgNo=18500

        svn log -v -r 35966
        svn log -v -r 35965

        Fix will be available from 12th March 2010 nightly
        http://download.java.net/glassfish/v3.1/nightly/


          People

          • Assignee:
            Jagadish
            Reporter:
            jajalvipul
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: