Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1_ms07
    • Component/s: verifier
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      11,596

      Description

      The attached war does not verify...

      here is the output at the command line...

      bash-3.2$ /export/home/vkraemer/GlassFish_v3/glassfish/bin/verifier
      /export/home/vkraemer/NetBeansProjects/WebApplication39/dist/WebApplication39.war
      Felix cache dir located at /tmp/verifier-cache/

      Welcome to Felix
      ================

      Feb 19, 2010 10:47:22 AM org.jvnet.hk2.osgiadapter.OSGiModulesRegistryImpl <init>
      WARNING: Cannot save metadata to cache
      java.io.IOException: No such file or directory
      at java.io.UnixFileSystem.createFileExclusively(Native Method)
      at java.io.File.createNewFile(File.java:883)
      at
      org.jvnet.hk2.osgiadapter.OSGiModulesRegistryImpl.saveCache(OSGiModulesRegistryImpl.java:218)
      at
      org.jvnet.hk2.osgiadapter.OSGiModulesRegistryImpl.<init>(OSGiModulesRegistryImpl.java:116)
      at
      org.jvnet.hk2.osgiadapter.OSGiFactoryImpl.createModulesRegistry(OSGiFactoryImpl.java:70)
      at
      org.jvnet.hk2.osgiadapter.OSGiFactoryImpl.createModulesRegistry(OSGiFactoryImpl.java:52)
      at org.jvnet.hk2.osgiadapter.HK2Main.createModulesRegistry(HK2Main.java:133)
      at org.jvnet.hk2.osgiadapter.HK2Main.start(HK2Main.java:121)
      at
      org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:640)
      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1700)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1622)
      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:915)
      at org.jvnet.hk2.osgimain.Main.start(Main.java:140)
      at
      org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:640)
      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1700)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1622)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1077)
      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
      at java.lang.Thread.run(Thread.java:619)
      INFO: Verifying: [ WebApplication39 ]
      WARNING: setRuntimeDDPresent method not implemented
      INFO: Compiling JSPs in [ WebApplication39 ]
      INFO:

      1. of Failures : 1
      2. of Warnings : 0
      3. of Errors : 0
        INFO: Look in file "WebApplication39.war.txt" for detailed results.
        Stopped org.apache.felix.framework [0]
        Error stopping framework: org.osgi.framework.BundleException: Bundle
        org.apache.felix.framework [0] cannot be stopped since it is already stopping.
        bash-3.2$

        Activity

        vince kraemer added a comment -

        Created an attachment (id=4240)
        the war fiile

        vince kraemer added a comment -

        Created an attachment (id=4241)
        the txt file generated by the verifier

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -
            • Issue 11743 has been marked as a duplicate of this issue. ***
        Sanjeeb Sahoo added a comment -

        svn -m "Verifier is now working on both Windows and Unix after switching to
        using new embedded api. These are the issues fixed:
        11394, 11572, 11573, 11595, 11596, 13568, 13569." commit

        Sending deployment/dol/osgi.bundle
        Sending persistence/cmp/support-ejb/osgi.bundle
        Sending verifier/verifier-impl/pom.xml
        Adding
        verifier/verifier-impl/src/main/java/com/sun/enterprise/tools/verifier/VerifierMain.java
        Sending
        verifier/verifier-impl/src/main/java/com/sun/enterprise/tools/verifier/VerifierModuleStartup.java
        Deleting
        verifier/verifier-impl/src/main/java/com/sun/enterprise/tools/verifier/VerifierOSGiMain.java
        Sending
        verifier/verifier-impl/src/main/java/com/sun/enterprise/tools/verifier/tests/webservices/WSSchemaLocation.java
        Sending verifier/verifier-scripts/src/main/resources/glassfish/bin/verifier
        Sending
        verifier/verifier-scripts/src/main/resources/glassfish/bin/verifier.bat
        Transmitting file data ........
        Committed revision 42661.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: