Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      11,631

      Description

      In some situations, v3 will fail to deploy an app after a very long time of very
      high activity.

      To reproduce:

      start v3 on a Windows system.
      use asadmin to attempt to deploy the attached war file.

      The system becomes very busy and eventually the deployment fails. (Eventually is
      on the order of minutes on a laptop with a 2.0 GHz Core 2 Duo CPU and 2GB of memory)

      The app also fails to deploy if you try to use directory deployment.

      This issue is related to http://netbeans.org/bugzilla/show_bug.cgi?id=181173

      1. server.log
        44 kB
        vince kraemer
      2. server.log
        21 kB
        vince kraemer
      3. server.log
        64 kB
        vince kraemer

        Activity

        vince kraemer added a comment -

        VBKMacBookPro:~ vkraemer$ date ; glassfishv3u1b7/glassfish/bin/asadmin deploy
        Downloads/WicketExamples.war ; date
        Thu Mar 4 09:28:54 PST 2010
        com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while loading the app :
        org.glassfish.deployment.common.DeploymentException: Java heap space

        Command deploy failed.
        Thu Mar 4 09:35:48 PST 2010

        vince kraemer added a comment -

        same mac

        different bits http://download.java.net/glassfish/v3.1/nightly/glassfish-v3_1-b01-02_27_2010.zip

        still fail

        VBKMacBookPro:~ vkraemer$ date ; glassfishv3dot1feb27/glassfish/bin/asadmin deploy
        Downloads/WicketExamples.war ; date
        Thu Mar 4 09:53:12 PST 2010
        com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while loading the app :
        org.glassfish.deployment.common.DeploymentException: Java heap space

        Command deploy failed.
        Thu Mar 4 10:00:43 PST 2010

        vince kraemer added a comment -

        Created an attachment (id=4254)
        failing to deploy... v3.1 on Mac OS X

        vince kraemer added a comment -

        it looks like this is a cross platform problem.

        vince kraemer added a comment -

        this appears to be resolved with the 2010-03-10 nightly build, which includes
        weld 1.0.1...


          People

          • Assignee:
            rogerk
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: