glassfish
  1. glassfish
  2. GLASSFISH-1172

Java2DB: Properties need to be passed to persistence provider to keep work when bug 1171 is fixed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 9.0pe
    • Fix Version/s: 9.1pe
    • Component/s: cmp
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      1,172

      Description

      The following bug will be fixed in TopLink Essentials.

      https://glassfish.dev.java.net/issues/show_bug.cgi?id=1171

      When it is fixed, in order for Java2DB to keep working a property will have to
      be included in the properties passed to createContainerEntityManagerFactory
      (PersistenceUnitInfo info, Map properties)

      The following property will be required:

      toplink.ddl-generation.output-mode=sql-script

      In addition, I have come comments and questions that can hopefully be addressed

      1. Can users of GlassFish make use of toplink.ddl-generation.output-
      mode=database? This should not be disallowed.
      2. Can users of GlassFish specify their own locations for createDDL.jdbc and
      dropDDL.jdbc. This should not be disallowed.
      3. Can users of GlassFish specify their own value for toplink.ddl-generation?
      This should not be disallowed.

        Issue Links

          Activity

          marina vatkina added a comment -

          Fixing the component first.

          marina vatkina added a comment -

          This has been already done as part of fix for issue
          https://glassfish.dev.java.net/issues/show_bug.cgi?id=901.

          The toplink.ddl-generation.output-mode=sql-script is set if not set by the user.
          None of the user settings are overwritten. There are probably no tests to verify
          that, but we can look into adding them. And if any special case is not working,
          a separate bug needs to be filed .

              • This issue has been marked as a duplicate of 901 ***

            People

            • Assignee:
              marina vatkina
              Reporter:
              tware
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: