glassfish
  1. glassfish
  2. GLASSFISH-11743

simplest web app does not verify successfully

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: 3.1_ms07
    • Component/s: verifier
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      11,743

      Description

      Here is the output for the 'failed test'...

      FAILED TESTS :
      --------------

      Test Name : tests.web.AllJSPsMustBeCompilable
      Test Assertion : All the JSPs that are bundled inside a web application must
      be compilable using a J2EE compliant JSP compiler that does not have any
      proprietary or optional features in it.
      Test Description : For [ WebApplication58 ]
      Error: Some JSPs bundled inside [ WebApplication58 ] could not be compiled. See
      details below.
      org.apache.jasper.JasperException: PWC6033: Error in Javac compilation for JSP

      PWC6199: Generated servlet error:
      string:///index_jsp.java:5: package javax.servlet.jsp does not exist

      PWC6199: Generated servlet error:
      string:///index_jsp.java:7: package org.apache.jasper.runtime does not exist

      PWC6199: Generated servlet error:
      string:///index_jsp.java:8: package org.apache.jasper.runtime does not exist

      PWC6199: Generated servlet error:
      string:///index_jsp.java:10: cannot find symbol
      symbol : class JspFactory
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:14: package org.glassfish.jsp.api does not exist

      PWC6199: Generated servlet error:
      string:///index_jsp.java:10: cannot find symbol
      symbol : variable JspFactory
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:23: cannot find symbol
      symbol : class PageContext
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:27: cannot find symbol
      symbol : class JspWriter
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:28: incompatible types
      found : org.apache.jsp.index_jsp
      required: java.lang.Object

      PWC6199: Generated servlet error:
      string:///index_jsp.java:29: cannot find symbol
      symbol : class JspWriter
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:30: cannot find symbol
      symbol : class PageContext
      location: class org.apache.jsp.index_jsp

      PWC6199: Generated servlet error:
      string:///index_jsp.java:42: package org.glassfish.jsp.api does not exist

      PWC6199: Generated servlet error:
      string:///index_jsp.java:46: cannot find symbol
      symbol : class SkipPageException
      location: class org.apache.jsp.index_jsp

      I will attach the war file.

        Activity

        vince kraemer added a comment -

        Created an attachment (id=4287)
        the war file

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -

        duplicate of 11596

            • This issue has been marked as a duplicate of 11596 ***

          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: