glassfish
  1. glassfish
  2. GLASSFISH-11744

simple ear file causes a st in the verifier

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: V3
    • Fix Version/s: 3.1_dev
    • Component/s: verifier
    • Labels:
      None
    • Environment:

      Operating System: Solaris
      Platform: Sun

    • Issuezilla Id:
      11,744

      Description

      bash-3.2$ test-install/sges-v3/glassfish/bin/verifier
      ~/NetBeansProjects/EnterpriseApplication6/dist/EnterpriseApplication6.ear
      Felix cache dir located at /tmp/verifier-cache/

      Welcome to Felix
      ================

      WARNING: Exception while starting bundle com.sun.enterprise.osgi-adapter [115]
      org.osgi.framework.BundleException: Activator start error in bundle
      com.sun.enterprise.osgi-adapter [115].
      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1751)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1622)
      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:915)
      at org.jvnet.hk2.osgimain.Main.start(Main.java:140)
      at
      org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:640)
      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1700)
      at org.apache.felix.framework.Felix.startBundle(Felix.java:1622)
      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1077)
      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at
      org.glassfish.javaee.full.deployment.EarHandler.getClassLoader(EarHandler.java:299)
      at
      com.sun.enterprise.tools.verifier.DescriptorFactory.createApplicationDescriptor(DescriptorFactory.java:140)
      at com.sun.enterprise.tools.verifier.Verifier.initStandalone(Verifier.java:336)
      at com.sun.enterprise.tools.verifier.Verifier.init(Verifier.java:144)
      at
      com.sun.enterprise.tools.verifier.VerifierModuleStartup.start(VerifierModuleStartup.java:103)
      at com.sun.enterprise.module.bootstrap.Main.launch(Main.java:457)
      at com.sun.enterprise.module.bootstrap.Main.launch(Main.java:401)
      at org.jvnet.hk2.osgiadapter.HK2Main.start(HK2Main.java:125)
      at
      org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:640)
      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1700)
      ... 9 more
      Stopped org.apache.felix.framework [0]
      Error stopping framework: org.osgi.framework.BundleException: Bundle
      org.apache.felix.framework [0] cannot be stopped since it is already stopping.

        Activity

        vince kraemer added a comment -

        Created an attachment (id=4288)
        the nasty ear file

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -

        All verifier bugs will be addressed by 3.1_ms7

        Sanjeeb Sahoo added a comment -

        It is true that verifier is completely broken and I am fixing it. As I fix it, I
        also noticed this NPE from EarHandler and had earlier filed issue 14538 against
        deployment. Since that is a much more pointed bug, I am closing this as a
        duplicate of that bug.

            • This issue has been marked as a duplicate of 14538 ***

          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            vince kraemer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: