glassfish
  1. glassfish
  2. GLASSFISH-11777

Authentication problem with servlets registered through HTTP service

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: v3.0.1
    • Component/s: OSGi-JavaEE
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

      Description

      I have installed the OSGI HTTP service through admin console and after that
      deployed the felix webconsole 2.0.6. This webconsole provides a webinterface for
      the installed OSGI bundles and uses default username/password = admin/admin.

      What happens is that I have to enter the username and password twice before the
      authentication succeeds. The issue is similar with the felix webconsole version
      3.0.0 but did not try that in detail. (should be checked as well for solving
      this bug).

      Since the felix webconsole registers the servlet through the HTTP service this
      problem is in the area of OSGI-Java EE integration.

        Activity

        kumara added a comment -

        Fix in 3.0.1

        Sanjeeb Sahoo added a comment -

        This is already fixed in trunk as part of revision #36233). No, committing fix
        to 3.0.1 branch:
        Sending
        osgi-javaee/osgi-http/src/main/java/org/glassfish/osgihttp/GlassFishHttpService.java
        Transmitting file data .
        Committed revision 36444.

        This will be part of v3.0.1 build #13.


          People

          • Assignee:
            Sanjeeb Sahoo
            Reporter:
            erikengerd
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: