glassfish
  1. glassfish
  2. GLASSFISH-11813

FINE messages are not logged to the server.log

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1
    • Component/s: logging
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      11,813

      Description

      After turning on the javax.enterprise.resource.resourceadapter logging level to
      FINEST in the logging.properties, some FINE messages were expected in the
      server.log for some debugging.

      There are no FINE messages logged from this logger. However INFO messages and
      levels above are logged. This is with the recent builds.

      This needs a fix asap as it affects some debugging.

        Activity

        carlavmott added a comment -

        I just tried some examples and I'm seeing this same behavior. I'm starting to
        look at this now.

        carlavmott added a comment -

        same bug as 11542. I have added comment in that bug. Please see and provide
        more information.

            • This issue has been marked as a duplicate of 11542 ***
        carlavmott added a comment -

        this is not a duplicate.

        carlavmott added a comment -

        passing this to Naman.

        marina vatkina added a comment -

        it affects all logs.

        carlavmott added a comment -

        when fixing a previous bug to set the thread id correctly I had over written the
        log method in Logger. I now over write that method by setting the thread id in
        the log record and call the parent to actually process the message. What I
        should have done previously.

        Fixing it now because so many folks are affected by this bug.

        hmeerlo added a comment -

        This still happens for me. It is impossible to get anything below INFO in the server.log. I'm running 3.1.1 with all the latest updates. Can it be re-opened?

        naman_mehta added a comment -

          People

          • Assignee:
            naman_mehta
            Reporter:
            Shalini
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: