glassfish
  1. glassfish
  2. GLASSFISH-11817

[regression] bmt_txlocal_apptimeout test failed to get web response

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: v3.0.1
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Sun

    • Issuezilla Id:
      11,817

      Description

      bmt_txlocal_apptimeout test failed to get web response

      On v3.0.1 b15, bmt_txlocal_apptimeout test gets null response.
      The same test passed on v3.0.1 b14.

      To reproduce the issue:
      do "ant all" with sqe env and in the directory of
      appserver-sqe/pe/transaction/bmt/txlocal/timeout/apptimeout

      To get test source and setup env, please refer core test instruction,
      http://agni-1.sfbay.sun.com/JSPWiki/Wiki.jsp?page=SQECoreFULL
      You can check out transaction module only with co-transaction.

      The same failure was reported in v2.1.2 previously.
      https://glassfish.dev.java.net/issues/show_bug.cgi?id=11747

        Activity

        sherryshen added a comment -

        To debug the failure on my local machine, the problem
        seems related to the usage of sleep.
        java.lang.InterruptedException: sleep interrupted

        do "ant clean build setup deploy" (no error)
        do "ant run" (see error at client and server below on b15, but not on b14)

        v3.0.1 b15 client output and server.log
        runweb:
        [webtest] Full Path of Result File->
        /space/test1/SRC/c301/appserver-sqe/reports/pe-pe/sparc_win60_SunOS/tx-gtest-results.xml
        [webtest] This is the new GTest version. in request dispatch...
        [webtest] Non SSL request...
        [webtest] In Session :bmt_txlocal_apptimeout
        [webtest] RedirectResponse=HTTP/1.0
        [webtest] authMethod OTHER
        [webtest] ERROR (false,true)in : GET
        /txbmt-txlocal-apptimeout-web/txbmt-txlocal-apptimeout?timeout=30 HTTP/1.0
        [webtest] Expected Output ****************************************
        [webtest] <html><head><title>AppTimeout Test Client</title></head><body>
        [webtest] <p>Got Home Object of Session Bean from JNDI Context
        [webtest] <p>Got EJB Object of Session Bean from home object
        [webtest] <p>Start Transaction with Timeout: 30
        [webtest] <p>Removed Stateful Bean
        [webtest] <p>Transaction Rolledback after Timeout
        [webtest] <p>BMT_TxLocal_AppTimeout STATUS: *PASSED*
        [webtest] </body></html>
        [webtest]
        [webtest] ********************************************************
        [webtest] Actual Output ##########################################
        [webtest] null
        [webtest] #####################################################
        [webtest] FAIL No description (GET
        /txbmt-txlocal-apptimeout-web/txbmt-txlocal-apptimeout?timeout=30 HTTP/1.0)
        [webtest] lastTask

        BUILD SUCCESSFUL
        Total time: 35 seconds
        test1@win60%

        [#|2010-04-23T09:13:05.126-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=27;_ThreadName=Thread-1;|setDivision() in Entity Bean|#]

        [#|2010-04-23T09:13:34.880-0700|WARNING|glassfish3.0|com.sun.grizzly.config.GrizzlyServiceListener|
        _ThreadID=15;_ThreadName=Thread-1;|Interrupting idle Thread:
        http-thread-pool-8080-(1)|#]

        [#|2010-04-23T09:13:34.881-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=27;_ThreadName=Thread-1;|Error! in doGet() of ServletClient|#]

        [#|2010-04-23T09:13:34.884-0700|SEVERE|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=27;_ThreadName=Thread-1;|java.lang.InterruptedException: sleep interrupted
        at java.lang.Thread.sleep(Native Method)
        at
        com.sun.s1peqe.transaction.bmt.txlocal.timeout.apptimeout.web.ServletClient.doGet(ServletClient.java:72)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:734)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
        at
        org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1523)
        at
        org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:279)
        at
        org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:188)
        at
        org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:641)
        at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:97)
        at
        com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingStandardPipeline.java:85)
        at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:185)
        at
        org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:332)
        at
        org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:233)
        at
        com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java:165)
        at com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
        at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
        at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
        at
        com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:170)
        at
        com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.java:135)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
        at com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
        at
        com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53)
        at
        com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
        at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
        at
        com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:330)
        at
        com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
        at java.lang.Thread.run(Thread.java:619)

        #]

        v3.0.1 b14 client output and server.log
        runweb:
        [webtest] Full Path of Result File->
        /space/test1/SRC/c301/appserver-sqe/reports/pe-pe/sparc_win60_SunOS/tx-gtest-results.xml
        [webtest] This is the new GTest version. in request dispatch...
        [webtest] Non SSL request...
        [webtest] In Session :bmt_txlocal_apptimeout
        [webtest] RedirectResponse=HTTP/1.0
        [webtest] authMethod OTHER
        [webtest] OK -->GET
        /txbmt-txlocal-apptimeout-web/txbmt-txlocal-apptimeout?timeout=30 HTTP/1.0
        [webtest] lastTask

        BUILD SUCCESSFUL
        Total time: 54 seconds
        [#|2010-04-23T09:25:33.844-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=25;_ThreadName=Thread-1;|setDivision() in Entity Bean|#]
        .....
        [#|2010-04-23T09:26:18.878-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=25;_ThreadName=Thread-1;|ejbPassivate() in Entity Bean|#]

        [#|2010-04-23T09:26:18.879-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=25;_ThreadName=Thread-1;|Expected Rollback Exception is thrown:
        javax.transaction.RollbackException: Transaction rolled back due to time out.|#]

        [#|2010-04-23T09:26:18.918-0700|INFO|glassfish3.0|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|
        _ThreadID=25;_ThreadName=Thread-1;|removeEntity() in Stateful Bean|#]

        Shing Wai Chan added a comment -

        If I change the timeout configuration from 30 to 10, then the test passes.

        Shing Wai Chan added a comment -

        This is fixed by grizzly integration 1.9.18-o.

        sherryshen added a comment -

        Verified the fix on v3.0.1 b16.


          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            sherryshen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: