glassfish
  1. glassfish
  2. GLASSFISH-11894

QuickLook weld/osgiweld test failed on b18

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Incomplete
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      11,894

      Description

      With the promoted b18, the weld/osgiweld test failed with following exceptions:
      [testng] java.lang.AssertionError: Unexpected Package Exports expected:<true>
      but was:<false>
      [testng] at
      test.weld.osgi.OsgiWeldTestNG.testOsgiModuleIntegrity(OsgiWeldTestNG.java:79)
      [testng] ... Removed 26 stack frames

      ...

      To reproduce:
      1. Start GF domain.
      2. IN quicklook/weld/osgiweld, run
      % ant -Dglassfish.home=[GF_Home] all

        Activity

        rogerk added a comment -

        I'll take a look.

        rogerk added a comment -

        That promoted build of Weld is still 1.0.1-SP1.
        Weld 1.0.1-SP2 was integrated the evening of May 12 - so it is available in the
        nightly builds. It should be available in the next promoted build.
        Try your quick look test against the latest nightly.

        mzh777 added a comment -
            • Issue 11893 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            rogerk
            Reporter:
            mzh777
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: