Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      11,985

      Description

      Hello All,

      I use netbeans IDE 6.9 GF v3 1 windows xp, i get this exception every time i try
      to deploy ejb application

      SEVERE: Exception while invoking class org.glassfish.ejb.startup.EjbDeployer
      load method
      java.lang.RuntimeException: EJB Container initialization error
      at
      org.glassfish.ejb.startup.EjbApplication.loadContainers(EjbApplication.java:219)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:197)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:63)
      at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:175)
      at
      org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:216)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.ja
      va:338)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.ja
      va:183)
      at
      org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:272)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:3
      05)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:3
      20)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1
      176)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:
      83)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRu
      nnerImpl.java:1235)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRu
      nnerImpl.java:1224)
      at
      com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:365)
      at
      com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:204)
      at
      com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:166)
      at
      com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java
      :245)
      at
      com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:17
      0)
      at
      com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.
      java:135)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at
      com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53
      )
      at
      com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:33
      0)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: Error while binding JNDI name
      registeration.RegisterationBeanRemote__3_x_Internal_RemoteBusinessHome__ for EJB
      : RegisterationBean
      at
      com.sun.ejb.containers.BaseContainer.initializeHome(BaseContainer.java:1530)
      at
      com.sun.ejb.containers.StatelessSessionContainer.initializeHome(StatelessSession
      Container.java:197)
      at
      com.sun.ejb.containers.ContainerFactoryImpl.createContainer(ContainerFactoryImpl
      .java:161)
      at
      org.glassfish.ejb.startup.EjbApplication.loadContainers(EjbApplication.java:207)
      ... 32 more
      Caused by: javax.naming.NameAlreadyBoundException [Root exception is
      org.omg.CosNaming.NamingContextPackage.AlreadyBound:
      IDL:omg.org/CosNaming/NamingContext/AlreadyBound:1.0]
      at
      com.sun.jndi.cosnaming.ExceptionMapper.mapException(ExceptionMapper.java:75)
      at com.sun.jndi.cosnaming.CNCtx.callBindOrRebind(CNCtx.java:595)
      at com.sun.jndi.cosnaming.CNCtx.bind(CNCtx.java:620)
      at com.sun.jndi.cosnaming.CNCtx.bind(CNCtx.java:658)
      at javax.naming.InitialContext.bind(InitialContext.java:400)
      at
      com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishCosNamingObject
      (GlassfishNamingManagerImpl.java:224)
      at
      com.sun.ejb.containers.BaseContainer$JndiInfo.publish(BaseContainer.java:5482)
      at
      com.sun.ejb.containers.BaseContainer.initializeHome(BaseContainer.java:1515)
      ... 35 more
      Caused by: org.omg.CosNaming.NamingContextPackage.AlreadyBound:
      IDL:omg.org/CosNaming/NamingContext/AlreadyBound:1.0
      at
      org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper.read(AlreadyBoundHelpe
      r.java:60)
      at org.omg.CosNaming._NamingContextStub.bind(_NamingContextStub.java:67)
      at com.sun.jndi.cosnaming.CNCtx.callBindOrRebind(CNCtx.java:584)
      ... 41 more

      SEVERE: Exception while loading the app
      java.lang.RuntimeException: EJB Container initialization error
      at
      org.glassfish.ejb.startup.EjbApplication.loadContainers(EjbApplication.java:219)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:197)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:63)
      at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:175)
      at
      org.glassfish.internal.data.ApplicationInfo.load(ApplicationInfo.java:216)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.ja
      va:338)
      at
      com.sun.enterprise.v3.server.ApplicationLifecycle.deploy(ApplicationLifecycle.ja
      va:183)
      at
      org.glassfish.deployment.admin.DeployCommand.execute(DeployCommand.java:272)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$1.execute(CommandRunnerImpl.java:3
      05)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:3
      20)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.doCommand(CommandRunnerImpl.java:1
      176)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl.access$900(CommandRunnerImpl.java:
      83)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRu
      nnerImpl.java:1235)
      at
      com.sun.enterprise.v3.admin.CommandRunnerImpl$ExecutionContext.execute(CommandRu
      nnerImpl.java:1224)
      at
      com.sun.enterprise.v3.admin.AdminAdapter.doCommand(AdminAdapter.java:365)
      at
      com.sun.enterprise.v3.admin.AdminAdapter.service(AdminAdapter.java:204)
      at
      com.sun.grizzly.tcp.http11.GrizzlyAdapter.service(GrizzlyAdapter.java:166)
      at
      com.sun.enterprise.v3.server.HK2Dispatcher.dispath(HK2Dispatcher.java:100)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java
      :245)
      at
      com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:791)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:693)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:954)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:17
      0)
      at
      com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.
      java:135)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at
      com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53
      )
      at
      com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:33
      0)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:309)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: Error while binding JNDI name
      registeration.RegisterationBeanRemote__3_x_Internal_RemoteBusinessHome__ for EJB
      : RegisterationBean
      at
      com.sun.ejb.containers.BaseContainer.initializeHome(BaseContainer.java:1530)
      at
      com.sun.ejb.containers.StatelessSessionContainer.initializeHome(StatelessSession
      Container.java:197)
      at
      com.sun.ejb.containers.ContainerFactoryImpl.createContainer(ContainerFactoryImpl
      .java:161)
      at
      org.glassfish.ejb.startup.EjbApplication.loadContainers(EjbApplication.java:207)
      ... 32 more
      Caused by: javax.naming.NameAlreadyBoundException [Root exception is
      org.omg.CosNaming.NamingContextPackage.AlreadyBound:
      IDL:omg.org/CosNaming/NamingContext/AlreadyBound:1.0]
      at
      com.sun.jndi.cosnaming.ExceptionMapper.mapException(ExceptionMapper.java:75)
      at com.sun.jndi.cosnaming.CNCtx.callBindOrRebind(CNCtx.java:595)
      at com.sun.jndi.cosnaming.CNCtx.bind(CNCtx.java:620)
      at com.sun.jndi.cosnaming.CNCtx.bind(CNCtx.java:658)
      at javax.naming.InitialContext.bind(InitialContext.java:400)
      at
      com.sun.enterprise.naming.impl.GlassfishNamingManagerImpl.publishCosNamingObject
      (GlassfishNamingManagerImpl.java:224)
      at
      com.sun.ejb.containers.BaseContainer$JndiInfo.publish(BaseContainer.java:5482)
      at
      com.sun.ejb.containers.BaseContainer.initializeHome(BaseContainer.java:1515)
      ... 35 more
      Caused by: org.omg.CosNaming.NamingContextPackage.AlreadyBound:
      IDL:omg.org/CosNaming/NamingContext/AlreadyBound:1.0
      at
      org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper.read(AlreadyBoundHelpe
      r.java:60)
      at org.omg.CosNaming._NamingContextStub.bind(_NamingContextStub.java:67)
      at com.sun.jndi.cosnaming.CNCtx.callBindOrRebind(CNCtx.java:584)
      ... 41 more
      any help please ?

      thanks in advance

        Activity

        marina vatkina added a comment -

        You can ask questions on the forum. If it's a bug, you need to have a
        reproducible test case


          People

          • Assignee:
            ksak
            Reporter:
            karkaur
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: