glassfish
  1. glassfish
  2. GLASSFISH-11986

domain fails to start when using JRockit

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Linux

    • Issuezilla Id:
      11,986

      Description

      Tested using promoted b19 and JRockit 4.0. Installation time created default
      domain fails to start because of a couple of jvm parameters.

      $ glassfish/bin/asadmin start-domain
      JVM failed to start: com.sun.enterprise.admin.launcher.GFLauncherException: The
      server exited prematurely with exit code 1.
      Before it died, it produced the following output:

      [WARN ][jrockit] MaxPermSize=192m ignored: Not a valid option for JRockit
      [WARN ][jrockit] NewRatio=2 ignored: Not a valid option for JRockit
      Unknown option or illegal argument: -XX:+LogVMOutput.
      Please check for incorrect spelling or review documentation of startup options.

      Could not create the Java virtual machine.

      Command start-domain failed.

      Work around;
      Comment out following 2 lines in domain.xml.

      <!--<jvm-options>-XX:+LogVMOutput</jvm-options>

      <jvm-options>-XX:LogFile=$

      {com.sun.aas.instanceRoot}

      /logs/jvm.log</jvm-options>
      -->

        Activity

        scatari added a comment -

        Transferring to appropriate category.

        Tom Mueller added a comment -

        This issue is fixed in 3.1. Did you want to keep this open for 3.0? Or can this
        be marked as resolved?

        See issue 12265.

        Tom Mueller added a comment -

        Dup of 12265

            • This issue has been marked as a duplicate of 12265 ***

          People

          • Assignee:
            scatari
            Reporter:
            ogino
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: