glassfish
  1. glassfish
  2. GLASSFISH-11999

Version class does not return correct branding when server is not running

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: v3.0.1
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      11,999

      Description

      I am filing this as P2 since it should be resolved for 3.0.1 release.

      'asadmin version' output when server is not running does not return values
      specified through branding extension. As the result, all distributions will
      return the same product name value, i.e. "GlassFish Server Open Source Edition".
      This is incorrect in the case of Oracle branded distributions.

      The root cause is that branding implementation is not being loaded by asadmin
      since it runs in non-HK2 mode.

        Activity

        Byron Nevins added a comment -

        Done.

        C:\gf_other\3.0.1>svn commit
        Sending admin\cli\pom.xml
        Sending
        admin\cli\src\main\java\com\sun\enterprise\admin\cli\VersionCommand.java
        Sending
        common\common-util\src\main\java\com\sun\appserv\server\util\VersionTemplate
        Transmitting file data ...
        Committed revision 37229.


          People

          • Assignee:
            Byron Nevins
            Reporter:
            Snjezana Sevo-Zenzerovic
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: