glassfish
  1. glassfish
  2. GLASSFISH-12151

EJB-5-1 Support libraries in classpath for Embeddable EJB API

    Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms02
    • Component/s: ejb_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      12,151

      Description

      In v3 single EJB module had to contain all dependencies. This also means that
      with more than 1 EJB module, PU cannot be shared between them.

        Issue Links

          Activity

          marina vatkina added a comment -

          dependencies

          marina vatkina added a comment -
              • Issue 11392 has been marked as a duplicate of this issue. ***
          marina vatkina added a comment -

          Libraries added to a single EJB module are supported now.

          marina vatkina added a comment -

          Library directory must have '.jar' suffix. Also added support for more than one
          directory called 'classes' (or any other duplicate directory name for that matter):

          Sending
          ejb/ejb-container/src/main/java/org/glassfish/ejb/embedded/DeploymentElement.java
          Sending
          ejb/ejb-container/src/main/java/org/glassfish/ejb/embedded/EJBContainerImpl.java
          Transmitting file data ..
          Committed revision 37734.


            People

            • Assignee:
              marina vatkina
              Reporter:
              marina vatkina
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: