glassfish
  1. glassfish
  2. GLASSFISH-12250

write after AynscContext.complete kills listener

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b06
    • Component/s: grizzly-kernel
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      12,250

      Description

      A well behaved application will not call any write methods on
      AsyncContext.getResponse().getWriter() after AsyncContext.complete() has been
      called. That said, Glassfish should handle the situation with a IOException,
      rather then:
      WARNING: Interrupting idle Thread: Grizzly-kernel-thread-21072(1)
      WARNING: Channel was unexpectedly closed
      resulting in the server refusing any more connections.

      Perhaps the OutputStream is not being closed properly?

        Activity

        Ryan Lubke added a comment -

        Taking ownership.

        Shing Wai Chan added a comment -
            • Issue 12259 has been marked as a duplicate of this issue. ***
        Ryan Lubke added a comment -

        Grizzly 1.9.19-beta5 has been integrated which includes the fix for this issue.

        Please verify using tonight's nightly build or the next promoted build (3.1-b06).

        Thanks!


          People

          • Assignee:
            Ryan Lubke
            Reporter:
            sparrow_ca
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: