glassfish
  1. glassfish
  2. GLASSFISH-12278

Embeddable EJB container does not work in 3.0.1

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1_ms07
    • Component/s: embedded
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      12,278

      Description

      I ran an EJB test in a trivial Maven project, and got the following error:

      javax.ejb.EJBException: No EJBContainer provider available
      The following providers:
      org.glassfish.ejb.embedded.EJBContainerProviderImpl
      Returned null from createEJBContainer call.

      I am attaching the build output, and the project as a zip.
      When I change the GF embeddable jar version to 3.0 in the pom file, it works fine.

        Activity

        sirajg added a comment -

        Without the fix, ejb-app directory is there in "java.io.tmpdir". With the fix,
        it is not.

        Diffs :

        ===================================================================
        — build.xml (revision 37857)
        +++ build.xml (working copy)
        @@ -78,9 +78,6 @@

        <rejar destfile="$

        {finaljar}" duplicate="preserve">
        <zipgroupfileset dir="${jardir}" includes="*/.jar"/>
        - <manifest>
        - <attribute name="Bundle-SymbolicName" value="${bundlename}"/>
        - </manifest>
        </rejar>
        </target>

        @@ -97,7 +94,11 @@
        </target>

        <target name="jar">
        - <jar destfile="${finaljar}

        " basedir="$

        {rootdir}/temp" />
        + <jar destfile="${finaljar}" basedir="${rootdir}

        /temp" >
        + <manifest>
        + <attribute name="Bundle-SymbolicName" value="$

        {bundlename}

        "/>
        + </manifest>
        + </jar>
        </target>

        sirajg added a comment -
            • Issue 12444 has been marked as a duplicate of this issue. ***
        pjiricka added a comment -

        Here are some related NetBeans bugs:
        http://netbeans.org/bugzilla/show_bug.cgi?id=187585
        http://netbeans.org/bugzilla/show_bug.cgi?id=190670

        BTW, is there any progress on this problem for GF 3.1?

        marina vatkina added a comment -

        It's a 3.0.1 error only

        Bhavanishankar added a comment -

        This works in v3.1.


          People

          • Assignee:
            Bhavanishankar
            Reporter:
            pjiricka
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: