glassfish
  1. glassfish
  2. GLASSFISH-12442

connection leak occured when connection validate failed

    Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1
    • Component/s: jdbc
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      12,442

      Description

      If connection validate fails in creating managed connection, a ResourceException
      will be throwed without destorying the created managed connection. It would
      cause a connection leak, as the created managed connection is not be returned
      and will never be destory.

      So i think in creating managed connection, the created managed connection should
      be closed before a ResourceException is throwed.

      1. fixForConnectionLeak.patch
        3 kB
        zhaojianyong
      2. fixForConnectionLeak.patch
        2 kB
        zhaojianyong
      3. fixForConnectionLeak.patch
        2 kB
        zhaojianyong

        Activity

        zhaojianyong added a comment -

        Created an attachment (id=4519)
        Fix for connection leak in creating managed connection

        zhaojianyong added a comment -

        Created an attachment (id=4520)
        Fix for connection leak in creating managed connection

        zhaojianyong added a comment -

        Sorry for attaching two pacthes with the same content.
        But how can I delete one of them?

        zhaojianyong added a comment -

        Created an attachment (id=4521)
        Fix for connection leak in creating managed connection with ignoring the ResourceException caused by mc.destory()

        Shalini added a comment -

        Duplicate of issue 17159.


          People

          • Assignee:
            Shalini
            Reporter:
            zhaojianyong
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: