Details

    • Type: New Feature New Feature
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms04
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      12,538

      Description

      Need to convert Admin Service -> SSL tab.

      All the files which is part of this page, /common/shared/sslPrepare.inc, sslButtons.inc and sslAttrs.inc
      needs to be converted

        Issue Links

          Activity

          Anissa Lam added a comment -

          MS3

          srinik76 added a comment -

          Index: src/main/resources/shared/sslButtons.inc
          ===================================================================
          — src/main/resources/shared/sslButtons.inc (revision 38609)
          +++ src/main/resources/shared/sslButtons.inc (working copy)
          @@ -42,12 +42,13 @@
          <!command
          convertCiphersItemsToStr(common="#

          {pageSession.selectedCommon}"
          ephemeral="#{pageSession.selectedEphemeral}"
          other="#{pageSession.selectedOther}" ecc="#{pageSession.selectedEcc}"
          ciphers="#{requestScope.ciphers}")
          mapPut(map="#{pageSession.valueMap}" key="Ssl3TlsCiphers"
          value="#{requestScope.ciphers}")
          - saveBeanAttributes(objectNameStr="#{pageSession.objectNameStr}"
          attrs="#{pageSession.valueMap}"
          - skipAttrs="#{pageSession.skipAttrsList}"
          - convertToFalse="#{pageSession.convertToFalseList}"
          + gf.createEntity(endpoint="#{pageSession.selfUrl}"
          + attrs="#{pageSession.valueMap}"
          + skipAttrs="#{pageSession.skipAttrsList}"
          + convertToFalse="#{pageSession.convertToFalseList}"
          );
          prepareSuccessfulMsg();
          - proxyExist(objectNameStr="#{pageSession.objectNameStr}"
          exist="#{requestScope.exist}")
          + gf.checkIfEndPointExist(endpoint="#{pageSession.selfUrl}"
          exists="#{requestScope.exist}")


          gf.redirect(page="#{selfPage}&alertType=${alertType}&alertSummary=${alertSummary}&alertDetail=${alertDetail}");
          />
          @@ -58,10 +59,7 @@
          <!command
          convertCiphersItemsToStr(common="#{pageSession.selectedCommon}

          "
          ephemeral="#

          {pageSession.selectedEphemeral}"
          other="#{pageSession.selectedOther}" ecc="#{pageSession.selectedEcc}"
          ciphers="#{requestScope.ciphers}")
          mapPut(map="#{pageSession.valueMap}" key="Ssl3TlsCiphers"
          value="#{requestScope.ciphers}")
          -
          createProxy(parentObjectNameStr="#{pageSession.parentObjectNameStr}"
          childType="#{pageSession.childType}"
          - attrs="#{pageSession.valueMap}"
          - convertToFalse="#{pageSession.convertToFalseList}"
          - result => $attribute{objStr});
          + gf.createEntity(endpoint="#{pageSession.selfUrl}"
          attrs="#{pageSession.valueMap}" convertToFalse="#{pageSession.convertToFalseList}");
          prepareSuccessfulMsg();

          gf.redirect(page="#{selfPage}&alertType=${alertType}&alertSummary=${alertSummary}&alertDetail=${alertDetail}");
          />
          Index: src/main/resources/shared/sslPrepare.inc
          ===================================================================
          — src/main/resources/shared/sslPrepare.inc (revision 38609)
          +++ src/main/resources/shared/sslPrepare.inc (working copy)
          @@ -35,10 +35,10 @@
          -->
          <!-- sslPrepare.inc -->

          -proxyExist(objectNameStr="#{pageSession.objectNameStr}"
          exist="#{requestScope.exist}")
          +gf.checkIfEndPointExist(endpoint="#{pageSession.selfUrl}"
          exists="#{requestScope.exist}")
          if (#{requestScope.exist}){
          setPageSessionAttribute(key="edit" value="#{true}" )
          - getProxyAttrs(objectNameStr="#{pageSession.objectNameStr}"
          valueMap="#{pageSession.valueMap}");
          + gf.getEntityAttrs(endpoint="#{pageSession.selfUrl}"
          valueMap="#{pageSession.valueMap}");

          convertToDifferentCiphersGroup(ciphers="#{pageSession.valueMap['Ssl3TlsCiphers']}"
          CommonCiphersList="#{pageSession.selectedCommon}"
          EphemeralCiphersList="#{pageSession.selectedEphemeral}

          "
          @@ -48,7 +48,7 @@
          }
          if (! #

          {requestScope.exist}

          ){
          setPageSessionAttribute(key="edit" value="#

          {false}" )
          - getDefaultProxyAttrs(
          parentObjectNameStr="#{pageSession.parentObjectNameStr}"
          childType="#{pageSession.childType}" valueMap="#{pageSession.valueMap}")+
          gf.getDefaultValues(endpoint="#{pageSession.selfUrl}",
          valueMap="#{pageSession.valueMap}")

          convertToDifferentCiphersGroup(ciphers="#{pageSession.valueMap['Ssl3TlsCiphers']}"
          CommonCiphersList="#{pageSession.selectedCommon}"
          EphemeralCiphersList="#{pageSession.selectedEphemeral}"
          Index: src/main/resources/configuration/jmxSSLEdit.jsf
          ===================================================================
          — src/main/resources/configuration/jmxSSLEdit.jsf (revision 38609)
          +++ src/main/resources/configuration/jmxSSLEdit.jsf (working copy)
          @@ -50,7 +50,6 @@
          setPageSessionAttribute(key="parentObjectNameStr"
          value="amx:pp=/domain/configs/config{pageSession.configName}/admin-service,type=jmx-connector,name=system")
          setPageSessionAttribute(key="childType" value="ssl")
          setPageSessionAttribute(key="showCancelButton" value="#{false}

          ")

          • setPageSessionAttribute(key="objectNameStr",
            value="amx:pp=/domain/configs/config[server-config]/admin-service/jmx-connector[system],type=ssl");
            setPageSessionAttribute(key="parentUrl",
            value="# {sessionScope.REST_URL}

            /configs/config/#

            {pageSession.configName}

            /admin-service/jmx-connector/system");
            setPageSessionAttribute(key="selfUrl",
            value="#

            {pageSession.parentUrl}

            /#

            {pageSession.childType}

            ");
            setPageSessionAttribute(key="rest-api" value="true");

          Checked in the changes for adminservice -> ssl tab. Still getProxyAttributes
          needs to be fixed, dependency Issue 12635

          srinik76 added a comment -

          getProxyAttributes needs to be converted. For this we need fix for 12635

          Anissa Lam added a comment -
              • Issue 12537 has been marked as a duplicate of this issue. ***
          Anissa Lam added a comment -

          Dependency has been resolved. MS4

          Anissa Lam added a comment -

          Feature

          srinik76 added a comment -

          getProxyAttribute(objectNameStr="amx:pp=/,type=runtime"
          attrName="SupportedCipherSuites" value="#

          {requestScope.supportedCiphers}

          ")

          The above call need to be converted to use rest api. For this need a hidden
          security command to get SupportedCipherSuites. Issue 12794 raised for this.
          Once the security creates the hidden cli 12794 needs to be transferred to rest
          team to create a url for this which can be used for GUI conversion.

          srinik76 added a comment -

          Dependency resolved, started working on rest conversion.

          srinik76 added a comment -

          Sending src/main/resources/shared/sslAttrs.inc
          Transmitting file data .
          Committed revision 39568.


            People

            • Assignee:
              srinik76
              Reporter:
              Anissa Lam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: