glassfish
  1. glassfish
  2. GLASSFISH-12804

start-instance fails in Felix if install path has a space

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: v3.0.1
    • Fix Version/s: 3.1
    • Component/s: OSGi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      12,804

      Description

      Using the trunk, r39076

      I unzipped glassfish.zip in C:\Documents and Settings\dipol\Desktop and tried to
      run start-domain. It fails in Felix with: java.net.MalformedURLException: no
      protocol: Settings\dipol\Desktop\glassfishv3\glassfish/modules/osgi-main.jar).

      Looks like an unquoted path issue. If I install in a path with no spaces the
      domain starts fine.

      Here is the output when the problem occurs.

      C:\Documents and Settings\dipol\Desktop\glassfishv3\glassfish\bin>asadmin start-
      domain --verbose
      Jul 26, 2010 2:38:36 PM com.sun.enterprise.admin.launcher.GFLauncherLogger info
      INFO: JVM invocation command line:
      C:\Program Files\Java\jdk1.6.0_07\bin\java.exe
      -cp
      C:/Documents and Settings/dipol/Desktop/glassfishv3/glassfish/modules/glassfish.
      jar
      -XX:+UnlockDiagnosticVMOptions
      -XX:MaxPermSize=192m
      -XX:NewRatio=2
      -XX:+LogVMOutput
      -XX:LogFile=C:\Documents and Settings\dipol\Desktop\glassfishv3\glassfish\domain
      s\domain1/logs/jvm.log
      -Xmx512m
      -client
      -javaagent:C:/Documents and Settings/dipol/Desktop/glassfishv3/glassfish/lib/mon
      itor/btrace-agent.jar=unsafe=true,noServer=true
      -Dosgi.shell.telnet.maxconn=1
      -Djdbc.drivers=org.apache.derby.jdbc.ClientDriver
      -Dfelix.fileinstall.dir=C:\Documents and Settings\dipol\Desktop\glassfishv3\glas
      sfish/modules/autostart/
      -Djavax.net.ssl.keyStore=C:\Documents and Settings\dipol\Desktop\glassfishv3\gla
      ssfish\domains\domain1/config/keystore.jks
      -Dosgi.shell.telnet.port=6666
      -Djava.security.policy=C:\Documents and Settings\dipol\Desktop\glassfishv3\glass
      fish\domains\domain1/config/server.policy
      -Dfelix.fileinstall.log.level=3
      -Dfelix.fileinstall.poll=5000
      -Dcom.sun.aas.instanceRoot=C:\Documents and Settings\dipol\Desktop\glassfishv3\g
      lassfish\domains\domain1
      -Dcom.sun.enterprise.config.config_environment_factory_class=com.sun.enterprise.
      config.serverbeans.AppserverConfigEnvironmentFactory
      -Dosgi.shell.telnet.ip=127.0.0.1
      -Djava.endorsed.dirs=C:\Documents and Settings\dipol\Desktop\glassfishv3\glassfi
      sh/modules/endorsed;C:\Documents and Settings\dipol\Desktop\glassfishv3\glassfis
      h/lib/endorsed
      -Dcom.sun.aas.installRoot=C:\Documents and Settings\dipol\Desktop\glassfishv3\gl
      assfish
      -Djava.ext.dirs=C:\Program Files\Java\jdk1.6.0_07/lib/ext;C:\Program Files\Java\
      jdk1.6.0_07/jre/lib/ext;C:\Documents and Settings\dipol\Desktop\glassfishv3\glas
      sfish\domains\domain1/lib/ext
      -Dfelix.fileinstall.bundles.new.start=true
      -Djavax.net.ssl.trustStore=C:\Documents and Settings\dipol\Desktop\glassfishv3\g
      lassfish\domains\domain1/config/cacerts.jks
      -Dcom.sun.enterprise.security.httpsOutboundKeyAlias=s1as
      -Djava.security.auth.login.config=C:\Documents and Settings\dipol\Desktop\glassf
      ishv3\glassfish\domains\domain1/config/login.conf
      -DANTLR_USE_DIRECT_CLASS_LOADING=true
      -Dorg.glassfish.web.rfc2109_cookie_names_enforced=false
      -Djava.library.path=C:/Documents and Settings/dipol/Desktop/glassfishv3/glassfis
      h/lib;C:/WINDOWS/system32;C:/Documents and Settings/dipol/Desktop/glassfishv3/gl
      assfish/bin;C:/WINDOWS/Sun/Java/bin;C:/WINDOWS;C:/Perl/site/bin;C:/Perl/bin;C:/P
      rogram Files/CollabNet Subversion Client;C:/WINDOWS/system32/wbem;C:/upx303w;C:/
      Program Files/Microsoft Visual Studio .NET 2003/Common7/IDE;C:/Program Files/Mic
      rosoft Visual Studio .NET 2003/VC/bin;C:/Program Files/Microsoft Platform SDK/Li
      b;C:/WINDOWS/local/upx303w;C:/local/apache-ant-1.7.1/bin;C:/Program Files/Java/j
      dk1.6.0_07/bin
      com.sun.enterprise.glassfish.bootstrap.ASMain
      -domainname
      domain1
      -asadmin-args
      start-domain,,,--verbose
      -instancename
      server
      -verbose
      true
      -debug
      false
      -asadmin-classpath
      C:/Documents and Settings/dipol/Desktop/glassfishv3/glassfish/modules/admin-cli.
      jar
      -asadmin-classname
      com.sun.enterprise.admin.cli.AsadminMain
      -upgrade
      false
      -type
      DAS
      -domaindir
      C:/Documents and Settings/dipol/Desktop/glassfishv3/glassfish/domains/domain1
      -read-stdin
      true
      Jul 26, 2010 2:38:36 PM com.sun.enterprise.admin.launcher.GFLauncherLogger info
      INFO: Successfully launched in 40 msec.
      Launching GlassFish on Felix platform
      OSGiGlassFishRuntime: Initialized + org.apache.felix.framework [0]
      Auto-properties install: reference:file:C:\Documents (org.osgi.framework.BundleE
      xception: Could not create bundle object. - java.io.FileNotFoundException: C:\Do
      cuments\META-INF\MANIFEST.MF (The system cannot find the path specified))
      org.osgi.framework.BundleException: Could not create bundle object.
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2593)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2441)
      at org.apache.felix.framework.BundleContextImpl.installBundle(BundleCont
      extImpl.java:129)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.processAutoPrope
      rties(AutoProcessor.java:120)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.process(AutoProc
      essor.java:71)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.la
      unchOSGiFrameWork(OSGiGlassFishRuntimeBuilder.java:124)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.bu
      ild(OSGiGlassFishRuntimeBuilder.java:80)
      at org.glassfish.experimentalgfapi.GlassFishRuntime.bootstrap(GlassFishR
      untime.java:77)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(
      GlassFishMain.java:112)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMa
      in.java:98)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:61)
      Caused by: java.io.FileNotFoundException: C:\Documents\META-INF\MANIFEST.MF (The
      system cannot find the path specified)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at org.apache.felix.framework.util.SecureAction.getFileInputStream(Secur
      eAction.java:436)
      at org.apache.felix.framework.cache.DirectoryRevision.getManifestHeader(
      DirectoryRevision.java:78)
      at org.apache.felix.framework.BundleImpl.createModule(BundleImpl.java:11
      21)
      at org.apache.felix.framework.BundleImpl.<init>(BundleImpl.java:79)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2536)
      ... 14 more
      Auto-properties install: and (org.osgi.framework.BundleException: Unable to cach
      e bundle: and - java.net.MalformedURLException: no protocol: and)
      org.osgi.framework.BundleException: Unable to cache bundle: and
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2485)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2441)
      at org.apache.felix.framework.BundleContextImpl.installBundle(BundleCont
      extImpl.java:129)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.processAutoPrope
      rties(AutoProcessor.java:120)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.process(AutoProc
      essor.java:71)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.la
      unchOSGiFrameWork(OSGiGlassFishRuntimeBuilder.java:124)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.bu
      ild(OSGiGlassFishRuntimeBuilder.java:80)
      at org.glassfish.experimentalgfapi.GlassFishRuntime.bootstrap(GlassFishR
      untime.java:77)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(
      GlassFishMain.java:112)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMa
      in.java:98)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:61)
      Caused by: java.net.MalformedURLException: no protocol: and
      at java.net.URL.<init>(URL.java:567)
      at org.apache.felix.framework.util.SecureAction.createURL(SecureAction.j
      ava:238)
      at org.apache.felix.framework.cache.JarRevision.initialize(JarRevision.j
      ava:150)
      at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:
      81)
      at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:
      59)
      at org.apache.felix.framework.cache.BundleArchive.createRevisionFromLoca
      tion(BundleArchive.java:1019)
      at org.apache.felix.framework.cache.BundleArchive.revise(BundleArchive.j
      ava:630)
      at org.apache.felix.framework.cache.BundleArchive.<init>(BundleArchive.j
      ava:146)
      at org.apache.felix.framework.cache.BundleCache.create(BundleCache.java:
      169)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2481)
      ... 14 more
      Auto-properties install: Settings\dipol\Desktop\glassfishv3\glassfish/modules/os
      gi-main.jar (org.osgi.framework.BundleException: Unable to cache bundle: Setting
      s\dipol\Desktop\glassfishv3\glassfish/modules/osgi-main.jar - java.net.Malformed
      URLException: no protocol: Settings\dipol\Desktop\glassfishv3\glassfish/modules/
      osgi-main.jar)
      org.osgi.framework.BundleException: Unable to cache bundle: Settings\dipol\Deskt
      op\glassfishv3\glassfish/modules/osgi-main.jar
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2485)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2441)
      at org.apache.felix.framework.BundleContextImpl.installBundle(BundleCont
      extImpl.java:129)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.processAutoPrope
      rties(AutoProcessor.java:120)
      at com.sun.enterprise.glassfish.bootstrap.AutoProcessor.process(AutoProc
      essor.java:71)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.la
      unchOSGiFrameWork(OSGiGlassFishRuntimeBuilder.java:124)
      at com.sun.enterprise.glassfish.bootstrap.OSGiGlassFishRuntimeBuilder.bu
      ild(OSGiGlassFishRuntimeBuilder.java:80)
      at org.glassfish.experimentalgfapi.GlassFishRuntime.bootstrap(GlassFishR
      untime.java:77)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(
      GlassFishMain.java:112)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMa
      in.java:98)
      at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:61)
      Caused by: java.net.MalformedURLException: no protocol: Settings\dipol\Desktop\g
      lassfishv3\glassfish/modules/osgi-main.jar
      at java.net.URL.<init>(URL.java:567)
      at org.apache.felix.framework.util.SecureAction.createURL(SecureAction.j
      ava:238)
      at org.apache.felix.framework.cache.JarRevision.initialize(JarRevision.j
      ava:150)
      at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:
      81)
      at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:
      59)
      at org.apache.felix.framework.cache.BundleArchive.createRevisionFromLoca
      tion(BundleArchive.java:1019)
      at org.apache.felix.framework.cache.BundleArchive.revise(BundleArchive.j
      ava:630)
      at org.apache.felix.framework.cache.BundleArchive.<init>(BundleArchive.j
      ava:146)
      at org.apache.felix.framework.cache.BundleCache.create(BundleCache.java:
      169)
      at org.apache.felix.framework.Felix.installBundle(Felix.java:2481)
      ... 14 more
      Auto-properties start: reference:file:C:\Documents (org.osgi.framework.BundleExc
      eption: Could not create bundle object. - java.io.FileNotFoundException: C:\Docu
      ments\META-INF\MANIFEST.MF (The system cannot find the path specified))
      Auto-properties start: and (org.osgi.framework.BundleException: Unable to cache
      bundle: and - java.net.MalformedURLException: no protocol: and)
      Auto-properties start: Settings\dipol\Desktop\glassfishv3\glassfish/modules/osgi
      -main.jar (org.osgi.framework.BundleException: Unable to cache bundle: Settings\
      dipol\Desktop\glassfishv3\glassfish/modules/osgi-main.jar - java.net.MalformedUR
      LException: no protocol: Settings\dipol\Desktop\glassfishv3\glassfish/modules/os
      gi-main.jar)

        Issue Links

          Activity

          Sanjeeb Sahoo added a comment -

          Sending
          osgi-platforms/equinox/src/main/resources/glassfish/osgi/equinox/configuration/config.ini
          Sending
          osgi-platforms/felix/src/main/resources/glassfish/osgi/felix/conf/config.properties
          Sending
          osgi-platforms/felix/src/main/resources/glassfish/osgi/felix/conf/config.properties.nojaxb
          Transmitting file data ...
          Committed revision 39088.


            People

            • Assignee:
              Sanjeeb Sahoo
              Reporter:
              Joe Di Pol
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: