Issue Details (XML | Word | Printable)

Key: GLASSFISH-12817
Type: New Feature New Feature
Status: Resolved Resolved
Resolution: Fixed
Priority: Blocker Blocker
Assignee: vijaysr
Reporter: Tom Mueller
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
glassfish

provide --target support for set command

Created: 27/Jul/10 10:33 AM   Updated: 26/Nov/10 12:13 AM   Resolved: 30/Jul/10 04:36 PM
Component/s: admin
Affects Version/s: 3.1
Fix Version/s: 3.1_ms04

Time Tracking:
Not Specified

Environment:

Operating System: All
Platform: All

Issue Links:
Dependency
 

Issuezilla Id: 12,817
Tags:
Participants: Hong Zhang, Tom Mueller and vijaysr


 Description  « Hide

This issue is for implementing command replication support for the set command.

The problem is the set command does not have a target. The target is derived
from the operands of the command and the replication framework will not be aware
of the targets. So there is no way for the framework to know where to send the
commands to. So just as deploy command, set also is a special case. It should be
executed only on DAS and once it is done on DAS, the command impl itself should
decide on replication targets and invoke some hidden command in the instances to
do the set there.

Because of this special treatment for set, Bill and Jerome want to be sure that
things will work - just as we did for deployment special case.



vijaysr added a comment - 27/Jul/10 02:54 PM

Taking ownership


Hong Zhang added a comment - 27/Jul/10 05:47 PM

One additional note: we need to decide what we will do for the set commands
with the top level elements. For example, setting the enabled attribute of the
application element to false in v2 will disable the application in all
referenced targets. Does that mean we should replicate the set command to all
instances which have the reference of this application?


vijaysr added a comment - 30/Jul/10 04:34 PM

asadmin set commands are replicated as applicable / required depending on the name value pair.

If an attribute for some resource is changed, then it is broadcast to all instances.

If an attribute for an application is changed, then it is replicated to all instances where the


vijaysr added a comment - 30/Jul/10 04:36 PM

asadmin set commands are replicated as applicable / required depending on the name value pair.

If an attribute for some resource is changed, then it is broadcast to all instances.

If an attribute for an application is changed, then it is replicated to all instances where the app has a ref

For all other attributes (configs.config.x-config or servers.server.y or nodes.node.z), the target is
derived from and replicated as applicable.

As for all commands, the command is executed on DAS and, if that succeeds, only then it is replicated
(if required).