glassfish
  1. glassfish
  2. GLASSFISH-12856

[Blocking] Cannot deploy to standalone instance: authentication issues

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b16
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: b13

      Standalone instance fails to start with the following error in server.log:

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|Apache
      Felix Remote Shell [147] Listener.Acceptor::activate()|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|java.net.BindException:
      Address already in use|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at java.net.PlainSocketImpl.socketBind(Native Method)|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:365)|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at java.net.ServerSocket.bind(ServerSocket.java:319)|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at java.net.ServerSocket.<init>(ServerSocket.java:185)|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at org.apache.felix.shell.remote.Listener$Acceptor.run(Listener.java:131)|#]

      [#|2010-07-30T15:40:16.864-0700|SEVERE|oracle-glassfish3.1|null|_ThreadID=15;_ThreadName=Thread-1;|
      at java.lang.Thread.run(Thread.java:619)|#]

      There are no other Glassfish processes on the system other than DAS. This is
      observed on two different systems (Solaris Sparc and x86).

      Steps to reproduce:
      1. asadmin create-local-instance, e.g.:

      1. asadmin --port 4848 --host lancer --passwordfile pass --user admin
        create-local-instance --node lancer sain1
        Using DAS host lancer and port 4848 from existing das.properties for node
        lancer. To use a different DAS, create a new node using create-node-ssh or
        create-node-config. Then create the instance with the new node and correct host
        and port:asadmin --host das_host --port das_port create-local-instance --node
        node_name instance_name.
        Attempting to rendezvous with DAS on host lancer port 4848
        Uptime: 1 days, 1 hours, 17 minutes, 58 seconds

      The instance has rendezvoused with the DAS and will be using host lancer port
      4848 for future communication.
      Automatically reassigned ports for server instance sain1 because the values in
      the config element are in use on the same host:
      JMX_SYSTEM_CONNECTOR_PORT=28687
      ASADMIN_LISTENER_PORT=24849
      HTTP_LISTENER_PORT=28081
      HTTP_SSL_LISTENER_PORT=28182

      Command create-local-instance executed successfully.

      2. asadmin start-local-instance, e.g.:

      1. asadmin --port 4848 --host lancer --passwordfile pass --user admin
        start-local-instance --node lancer sain1
        Waiting for the server to start .......................
        Successfully started the instance: sain1
        instancelocation:
        /export/home/j2eetest/v3.1/glassfishv3/glassfish/nodeagents/lancer/sain1
        Log File:
        /export/home/j2eetest/v3.1/glassfishv3/glassfish/nodeagents/lancer/sain1/logs/server.log
        Admin Port: 24849
        Command start-local-instance executed successfully.

      3. List instances and check instance's server.log for the exception.

      1. deploy-to-instance.debug
        7 kB
        lidiam
      2. list-instances.debug
        2 kB
        lidiam
      3. server.log
        41 kB
        lidiam
      4. start-local-instance.debug
        44 kB
        lidiam

        Issue Links

          Activity

          Tom Mueller added a comment -

          A domain that has a password and instances is not yet supported. This is in the
          process of being designed and implemented by Tim; assigning to him.

          As a work-around to proceed with testing, create the domain without a password.

          Tom Mueller added a comment -
              • Issue 12892 has been marked as a duplicate of this issue. ***
          Tom Mueller added a comment -

          Tim, please escalate if this isn't going to make it for MS4.

          Tim Quinn added a comment -

          I have checked in an interim fix for this, to allow testing to proceed.

          This will be replaced with the full implementation of admin traffic security
          later, but for now this will allow servers to accept admin commands from each
          other, even if admin users have been set up.

          Date: 2010-08-11 23:12:04+0000
          New Revision: 39613

          Modified:

          trunk/v3/admin/util/src/main/java/com/sun/enterprise/admin/remote/RemoteAdminCommand.java
          trunk/v3/core/kernel/src/main/java/com/sun/enterprise/v3/admin/AdminAdapter.java

          lidiam added a comment -

          Verified in promoted build b43.


            People

            • Assignee:
              Tim Quinn
              Reporter:
              lidiam
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: