glassfish
  1. glassfish
  2. GLASSFISH-12891

Caching an empty response freezes webapp

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: V3
    • Fix Version/s: 3.1_b14
    • Component/s: web_container
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      12,891

      Description

      The web application can return a response page with empty content.
      If this page is requested for the first time, it is correctly returned.
      If this page is requested for the second time, there is no response and the web
      application is not accessible any more. The Admin interface can still be accessed.
      It seems that the cache fails when serving an empty file.

      Happens on a vanilla installation of glassfish 3 and the following cache
      settings in sun.web.xml:

      <cache enabled="true" max-entries="4096" timeout-in-seconds="30">
      <cache-mapping>
      <servlet-name>dispatcher</servlet-name>
      </cache-mapping>
      </cache>

      The problem also occurrs on v2.1.1

        Activity

        Shing Wai Chan added a comment -

        We find similar issue when a servlet throw an exception.

        Shing Wai Chan added a comment -

        Sending
        web/web-glue/src/main/java/com/sun/appserv/web/cache/filter/CachingFilter.java
        Sending
        web/web-glue/src/main/java/com/sun/appserv/web/cache/filter/CachingResponseWrapper.java
        Transmitting file data ..
        Committed revision 39422.

        Shing Wai Chan added a comment -

        add test case:

        Sending build.xml
        Adding cachingHang
        Adding cachingHang/WebTest.java
        Adding cachingHang/build.properties
        Adding cachingHang/build.xml
        Adding cachingHang/descriptor
        Adding cachingHang/descriptor/glassfish-web.xml
        Adding cachingHang/servlet
        Adding cachingHang/servlet/test
        Adding cachingHang/servlet/test/TestServlet.java
        Adding cachingHang/servlet/test/TestServlet2.java
        Transmitting file data .......
        Committed revision 39425.

        Amy Roh added a comment -
            • Issue 3861 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Shing Wai Chan
            Reporter:
            hschack
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: