glassfish
  1. glassfish
  2. GLASSFISH-12938

Glassfish eats all CPU during OSGi Bundle deployment

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: Linux

    • Issuezilla Id:
      12,938

      Description

      Hi *,

      in promoted build 14 I encountered a problem when deploying a bunch of bundles
      at once to glassfish using the directory .../autodeploy/bundles/.

      The problem is that glassfish begins to deploy but then somehow gets confused,
      resulting in really stressing my 4-core AMD64:

      Tasks: 279 total, 1 running, 275 sleeping, 0 stopped, 3 zombie
      Cpu(s): 99.3%us, 0.7%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
      Mem: 8061556k total, 6738908k used, 1322648k free, 20936k buffers
      Swap: 11880032k total, 204344k used, 11675688k free, 1467324k cached

      PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
      26972 chaoslay 20 0 2747m 1.1g 5144 S 392 14.5 2223:33 java

      This happened at server startup but also occurred in another form (eating "just"
      2 cores during hot-deployment).

      I'll attach a server.log (from netbeans server log view, not the original file
      as it hasn't been written by glassfish) containing the complete startup and
      additionally I'll attach a small strace -f from the glassfish java process
      during its hang.

      1. gf-strace.log
        361 kB
        chaoslayer
      2. jstack_2_b15.txt
        62 kB
        chaoslayer
      3. jstack_2.txt
        46 kB
        chaoslayer
      4. jstack_3.txt
        48 kB
        chaoslayer
      5. jstack.txt
        60 kB
        chaoslayer
      6. server.netbeans.log
        162 kB
        chaoslayer

        Activity

        chaoslayer added a comment -

        ^^ Attached a test case WAB (~ 6.0 MiB). Sometimes the deployment gets stuck
        when glassfish comes up and sometimes only after one or two "touches" of that
        bundle.

        Sanjeeb Sahoo added a comment -

        Re-categorising since this is a generic deployment issue. Marking the issue
        started as Jerome has started to investigate this.

        Harald Wellmann added a comment -

        I have the same kind of problem on 3.1-b15 with a plain old WAR (no OSGI
        headers), using asadmin deploy.

        dochez added a comment -

        some threading issues were uncoverered when parsing mutilple jar files simultaneously. Fixed all
        discovered issues, will be available in b16.

        chaoslayer added a comment -

        Thanx for fixing this issue.


          People

          • Assignee:
            dochez
            Reporter:
            chaoslayer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: