glassfish
  1. glassfish
  2. GLASSFISH-13023

[UB]DOC. Describe how to setup a correct java on the remote machine

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms08
    • Component/s: docs
    • Labels:
      None
    • Environment:

      Operating System: Windows (generic)
      Platform: All

      Description

      Any remote asadmin command needs in java on the remote machine and such
      command use just a default java, if appserver was installed through unzipping
      an archive. Users have to be advised to execute from machine A: ssh <machine B>
      java -version. And if it is not JDK 6, change it. For example, on Solaris and
      Linux recreate /usr/bin/java link pointing to the suitable java.
      Or by setting AS_JAVA pointing on the correrct java in config/asenv.conf on the
      remote machine

      Also I want to mention that usually /usr/bin/java is linked with jdk 4 or 5.
      So there will be error messages (for jdk4 a bad error message).

        Activity

        sherryshen added a comment -

        Thank Elena for filing this bug.
        Before jdk is configured as Elena described on Solaris
        10 sparc machine, I saw the create-instance failure as
        below.

        [2010-08-18T00:58:15.96] # Actual:
        /export/hudson/workspace/sherry-clise1/glassfishv3/glassfish/bin/asadmin --user
        admin --host asqe-sb-7 --port 4848 create-node-ssh --nodehost asqe-sb-8
        --installdir /export/hudson/workspace/sherry-clise2/glassfishv3/glassfish
        asqe-sb-8_agent
        [2010-08-18T00:58:15.96]
        [2010-08-18T00:58:20.70] Command create-node-ssh executed successfully.
        ......
        [2010-08-18T00:58:32.86] # Actual:
        /export/hudson/workspace/sherry-clise1/glassfishv3/glassfish/bin/asadmin --user
        admin --host asqe-sb-7 --port 4848 create-instance --node asqe-sb-8_agent
        --systemproperties
        HTTP_LISTENER_PORT=46328:HTTP_SSL_LISTENER_PORT=46331:IIOP_LISTENER_PORT=46334:IIOP_SSL_LISTENER_PORT=46337:IIOP_SSL_MUTUALAUTH_PORT=46340:JMX_SYSTEM_CONNECTOR_PORT=46343
        sa_server2
        [2010-08-18T00:58:32.86] Command create-instance failed.
        [2010-08-18T00:58:39.04] remote failure: GlassFish requires Java SE version 6.
        Your JDK is version 5
        [2010-08-18T00:58:39.04]

        Paul Davies added a comment -

        Added [UB] to Summary to denote unbundled documentation.

        Reassigned to sfordin as this information should probably be added to the
        Installation Guide or Release Notes.

        sherryshen added a comment -
            • Issue 14115 has been marked as a duplicate of this issue. ***
        sherryshen added a comment -
            • Issue 14115 has been marked as a duplicate of this issue. ***
        Scott Fordin added a comment -

        Can you please provide a clearer explanation of the issue and solution here?

        Scott Fordin added a comment -

        This seems to be pretty much a duplicate of http://java.net/jira/browse/GLASSFISH-13943. Specifically, we clearly state the JDK requirements, and we clearly tell users that there are a whole bunch of things that can go wrong if the user chooses to not use the right Java version, so I don't think we should be telling user how to not use the right version.

        sherryshen added a comment -

        After cluster is created and run, the error can occur at app runtime,
        JSP compile failure due to JRE in use on Win2008 +MKS9.2 in
        http://java.net/jira/browse/GLASSFISH-16271
        The solution is to set AS_JAVA in asenv.conf.

        Scott Fordin added a comment -

        Added issue to 3.1 Release Notes.

        Scott Fordin added a comment -

        Restructured the Java Paths and Environment Settings section in the 3.1-3.1.1 Release Notes; divided it into several subsections that can be pointed to from other books. For example, I added pointer from the Installation Guide to this reworked section.


          People

          • Assignee:
            Scott Fordin
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - Not Specified
              Not Specified
              Remaining:
              Time Spent - 30 minutes Remaining Estimate - 6 hours
              6h
              Logged:
              Time Spent - 30 minutes Remaining Estimate - 6 hours
              30m