glassfish
  1. glassfish
  2. GLASSFISH-13065

Navigation tree fails to update when clicking on alerts in the header

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Macintosh

    • Issuezilla Id:
      13,065

      Description

      GlassFish notifies the user when updated packages are available. While on the "applications" tree node
      viewing deployed applications, I clicked on the "There are 1 update(s) available." link. The main panel
      updated correctly, but the navigation tree node still highlighted "Applications". The navigation tree should
      highlight the "Update Tool" tree node to reflect correct location.

        Activity

        Hide
        jclingan added a comment -

        Created an attachment (id=4722)
        Incorrect Navigation Tree highlight.

        Show
        jclingan added a comment - Created an attachment (id=4722) Incorrect Navigation Tree highlight.
        Hide
        Anissa Lam added a comment -

        This is a more general issue of tree highlights when clicking on the alerts in
        the 'notification' panel.
        So, click on 'check update', 'server restarted required' all have the same issue.
        Transfer to Ken to take a look.

        Show
        Anissa Lam added a comment - This is a more general issue of tree highlights when clicking on the alerts in the 'notification' panel. So, click on 'check update', 'server restarted required' all have the same issue. Transfer to Ken to take a look.
        Hide
        kenpaulsen added a comment -

        This is not really a tree issue... the pages are not passing the right
        information. The pages must highlight a VALID tree node. In virtually every
        single case where the "tree" is broken, it is really because the page is not
        written correct and is not passing in the right value.

        I fixed the Update Center pages. I am going to close this issue... if other
        occurrences are found, either fix or file a specific issue so it can be
        addressed. -Ken

        Show
        kenpaulsen added a comment - This is not really a tree issue... the pages are not passing the right information. The pages must highlight a VALID tree node. In virtually every single case where the "tree" is broken, it is really because the page is not written correct and is not passing in the right value. I fixed the Update Center pages. I am going to close this issue... if other occurrences are found, either fix or file a specific issue so it can be addressed. -Ken

          People

          • Assignee:
            kenpaulsen
            Reporter:
            jclingan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: