glassfish
  1. glassfish
  2. GLASSFISH-13128

java.lang.NoClassDefFoundError: org/jboss/weld/logging/messages/BeanManagerMessage

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms07
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      13,128
    • Status Whiteboard:

      weld-int-required

      Show
      weld-int-required

      Description

      While running arquillian tests against glassfish v3, the tests are not deployed
      and I see the below in the server log:

      Please find the webarchive created while running the tests.

      #|2010-08-
      24T09:22:07.926+0530|SEVERE|glassfish3.1|javax.enterprise.system.core.com.sun.en
      terprise.v3.server|_ThreadID=14;_ThreadName=Thread-1;|Exception while loading
      the app|#]

      [#|2010-08-
      24T09:22:08.007+0530|SEVERE|glassfish3.1|com.sun.enterprise.v3.server.Applicatio
      nConfigListener|_ThreadID=14;_ThreadName=Thread-1;|Error during enabling:
      java.lang.Exception: Exception while loading the app :
      org.glassfish.deployment.common.DeploymentException:
      java.lang.NoClassDefFoundError:
      org/jboss/weld/logging/messages/BeanManagerMessage
      at
      com.sun.enterprise.v3.server.ApplicationConfigListener.enableApplication(Applica
      tionConfigListener.java:212)
      at
      com.sun.enterprise.v3.server.ApplicationConfigListener.handleAppEnableChange(App
      licationConfigListener.java:147)
      at
      com.sun.enterprise.v3.server.ApplicationConfigListener.transactionCommited(Appli
      cationConfigListener.java:121)
      at
      org.jvnet.hk2.config.Transactions$TransactionListenerJob.process(Transactions.ja
      va:335)
      at
      org.jvnet.hk2.config.Transactions$TransactionListenerJob.process(Transactions.ja
      va:326)
      at
      org.jvnet.hk2.config.Transactions$ListenerNotifier$1.call(Transactions.java:202)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at org.jvnet.hk2.config.Transactions$Notifier$1.run(Transactions.java:158)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:8
      86)
      at
      java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:619)

      #]

        Activity

        Sreekanth added a comment -

        Created an attachment (id=4740)
        sample test application

        Sreekanth added a comment -

        Steps to reproduce:
        ==================
        1)Check out the GIT workspace from http://github.com/weld/core.git
        2)Add glassfish-remote-3 profile to pom.xml
        3)Run mvn test -Pglassfish-remote-3
        You will see the deployment problems in glassfish v3 server log.

        Sivakumar Thyagarajan added a comment -

        Created an attachment (id=4755)
        weld-osgi-bundle pom diff to fix NoClassDefFoundError in 13128

        Sivakumar Thyagarajan added a comment -

        It appears that the test application uses some internal Weld artifacts such as
        BeanManagerImpl and this class in turn has references to ch.qos.cal10n API and
        some exception classes. These packages were not exported by the weld osgi bundle
        as they are not traditionally used by normal applications. Fixing the weld osgi
        bundle pom to export these packages resulted in the application deploying fine.

        I have attached a diff of the weld-osgi-bundle pom.xml with the relevant
        changes. Since bringing these changes to GlassFish would need an integration, I
        would, for a short-term solution, provide the submitter a modified
        weld-osgi-bundle.jar that could be update in the modules directory for the tests
        to run.

        Sivakumar Thyagarajan added a comment -

        Analysis complete, need to push this to Weld bundle's OSGi headers. Targetting
        for MS7

        Sivakumar Thyagarajan added a comment -

        Marking as weld-int-required and this is a duplicate of issue 13713

            • This issue has been marked as a duplicate of 13713 ***

          People

          • Assignee:
            Sivakumar Thyagarajan
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: