glassfish
  1. glassfish
  2. GLASSFISH-13215

Improve an error message, when a directory deployment failed.

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b30
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: other
      Platform: Sun

    • Issuezilla Id:
      13,215

      Description

      Build 18, 08/31.

      In a case when a directory deployment failed, because the directory is not
      presented on the remote machine, will be seen such error mesage:

      remote failure: A supplemental command failed; cannot proceed further
      Command _instanceValidateRemoteDirDeployment failed on server instance in2 :
      java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

      I think that in this case has to be created an error message that would tell a
      user what happened.

        Activity

        Hong Zhang added a comment -

        assign to tim to take a look

        Tim Quinn added a comment -

        Setting target MS to MS 7.

        Tim Quinn added a comment -
            • Issue 13913 has been marked as a duplicate of this issue. ***
        Tim Quinn added a comment -

        Fix checked in.

        Author: tjquinn
        Date: 2010-11-13 05:59:53+0000
        New Revision: 42790

        Modified:

        trunk/v3/admin/util/src/main/java/com/sun/enterprise/admin/remote/RemoteAdminCommand.java

        Tim Quinn added a comment -
            • Issue 12433 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Tim Quinn
            Reporter:
            easarina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: