glassfish
  1. glassfish
  2. GLASSFISH-1334

Stack trace -- Unexpected Broker Internal Error : [null]

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 9.1pe
    • Fix Version/s: 9.1pe
    • Component/s: jms
    • Labels:
      None
    • Environment:

      Operating System: Linux
      Platform: PC

    • Issuezilla Id:
      1,334

      Description

      Build 21

      install gf, using setup-cluster.xml

      start the server

      stack trace in log.

        Issue Links

          Activity

          vince kraemer added a comment -

          Created an attachment (id=517)
          relevant log info

          vince kraemer added a comment -

          poor error message.

          gfbugbridge added a comment -

          <BT6543333>

          sridatta added a comment -

          Assigning to jms subcategory

          Sivakumar Thyagarajan added a comment -

          Requesting Ramesh to investigate.

          rampsarathy added a comment -

          The server.log does show the actual cause of the problem
          "Caused by:
          com.sun.messaging.jmq.jmsserver.multibroker.fullyconnected.LoopbackAddressException:
          Loopback IP address is not allowed in broker address
          ubuntuabihsot/127.0.0.1:7676 (imqbroker, mq://127.0.0.1:7676/,
          [4497704446284569600]) "

          but unfortunately it gets wrapped in a broker exception
          "[#|2006-10-18T13:51:34.332-0700|WARNING|sun-appserver-ee9.1|javax.enterprise.system.stream.err|_ThreadID=10;_ThreadName=main;_RequestID=530667c3-cfef-488c-9d95-3d871c5e16cd;|[18/Oct/2006:13:51:34
          PDT] ERROR [B3100]: Unexpected Broker Internal Error : [null] :"

          We can fix the InboundResourceAdapter code to get the actual exception and throw
          it wrather than the wrapped exception. But this is only a cosmetic issue, the
          error is shown in the log, and only needs an improvement ,

          Fix
          http://fisheye5.cenqua.com/changelog/glassfish/?cs=MAIN:rampsarathy:20061113135154


            People

            • Assignee:
              rampsarathy
              Reporter:
              vince kraemer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: