glassfish
  1. glassfish
  2. GLASSFISH-13360

upgrade of v2->v3 domain failed with ejb application

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b20
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      When upgrading v2 to v3 domain, the upgrade of an ear application failed (the
      ear contains a simple web module and ejb module, the web component invoking the
      remote ejb).

      I will attach the application I used and the upgrade server.log. The following
      are snippets of the server.log when it tries to load ejb.

      #|2010-09-09T20:35:53.002-
      0400|WARNING|glassfish3.1|javax.enterprise.system.util.org.glassfish.enterprise.
      iiop.util|_ThreadID=23;_ThreadName=Thread-1;|No default ThreadPool defined
      com.sun.corba.ee.spi.orbutil.threadpool.NoSuchThreadPoolException
      at
      org.glassfish.enterprise.iiop.util.S1ASThreadPoolManager.getThreadPool
      (S1ASThreadPoolManager.java:246)
      at
      org.glassfish.enterprise.iiop.util.S1ASThreadPoolManager.getDefaultThreadPool
      (S1ASThreadPoolManager.java:276)
      at org.glassfish.enterprise.iiop.impl.PEORBConfigurator.configure
      (PEORBConfigurator.java:138)
      at com.sun.corba.ee.impl.orb.ORBConfiguratorImpl.runUserConfigurators
      (ORBConfiguratorImpl.java:189)
      at com.sun.corba.ee.impl.orb.ORBConfiguratorImpl.configure
      (ORBConfiguratorImpl.java:174)
      at com.sun.corba.ee.impl.orb.ORBImpl.postInit(ORBImpl.java:598)
      at com.sun.corba.ee.impl.orb.ORBImpl.set_parameters(ORBImpl.java:689)
      at com.sun.corba.ee.impl.orb.ORBImpl.setParameters(ORBImpl.java:676)
      at com.sun.corba.ee.spi.osgi.ORBFactory.initialize(ORBFactory.java:107)
      at org.glassfish.enterprise.iiop.impl.GlassFishORBManager.initORB
      (GlassFishORBManager.java:576)
      at org.glassfish.enterprise.iiop.impl.GlassFishORBManager.getORB
      (GlassFishORBManager.java:262)
      at org.glassfish.enterprise.iiop.impl.GlassFishORBFactoryImpl.createORB
      (GlassFishORBFactoryImpl.java:93)
      at org.glassfish.enterprise.iiop.api.GlassFishORBHelper.getORB
      (GlassFishORBHelper.java:120)
      at
      org.glassfish.enterprise.iiop.api.GlassFishORBHelper.getProtocolManager
      (GlassFishORBHelper.java:187)
      at com.sun.ejb.containers.BaseContainer.initializeProtocolManager
      (BaseContainer.java:816)
      at com.sun.ejb.containers.BaseContainer.<init>(BaseContainer.java:564)
      at com.sun.ejb.containers.StatelessSessionContainer.<init>
      (StatelessSessionContainer.java:155)
      at com.sun.ejb.containers.StatelessSessionContainer.<init>
      (StatelessSessionContainer.java:149)
      at com.sun.ejb.containers.ContainerFactoryImpl.createContainer
      (ContainerFactoryImpl.java:105)
      at org.glassfish.ejb.startup.EjbApplication.loadContainers
      (EjbApplication.java:224)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:256)
      at org.glassfish.ejb.startup.EjbDeployer.load(EjbDeployer.java:97)
      at org.glassfish.internal.data.ModuleInfo.load(ModuleInfo.java:176)
      at org.glassfish.internal.data.ApplicationInfo.load
      (ApplicationInfo.java:238)
      at com.sun.enterprise.v3.server.ApplicationLifecycle.deploy
      (ApplicationLifecycle.java:400)
      ...

      [#|2010-09-09T20:35:53.043-
      0400|WARNING|glassfish3.1|javax.enterprise.resource.corba.ee.INITIALIZING.orb.
      lifecycle|_ThreadID=23;_ThreadName=Thread-1;|"IOP00910207: (INITIALIZE)
      Exception occured while running a user configurator"
      org.omg.CORBA.INITIALIZE: vmcid: SUN minor code: 207 completed: No
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.userConfiguratorException
      (ORBUtilSystemException.java:5491)
      at
      com.sun.corba.ee.impl.logging.ORBUtilSystemException.userConfiguratorException
      (ORBUtilSystemException.java:5509)

      ...
      Caused by: java.lang.NullPointerException
      at org.glassfish.enterprise.iiop.impl.PEORBConfigurator.configure
      (PEORBConfigurator.java:139)
      at com.sun.corba.ee.impl.orb.ORBConfiguratorImpl.runUserConfigurators
      (ORBConfiguratorImpl.java:189)
      ... 38 more

        Activity

        Hong Zhang added a comment -

        fix checked in

        Hong Zhang added a comment -

        Fixed the issue from deployment side. Turn off ApplicationConfigListener during
        upgrade so we won't try to load up applications when some of the subsystems are
        not fully initialized.

        Hong Zhang added a comment -

        Created an attachment (id=4860)
        the application that I used

        Hong Zhang added a comment -

        Created an attachment (id=4859)
        upgrade log

        Hong Zhang added a comment -

        This problem actually only happens during upgrade. After the upgrade finishes
        and restart server, the application could be loaded as expected. Is it somehow
        some part of the orb initialization is not complete during upgrade?


          People

          • Assignee:
            Hong Zhang
            Reporter:
            Hong Zhang
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: