Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b30
    • Component/s: standalone_client
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      13,410

      Description

      Several issues:

      • Invoking it without arguments leads to Microsoft runtime error:

      D:\GFv3.1\glassfish-3.1-b19-09_09_2010\glassfishv3>glassfish\bin\appclient.bat
      D:\GFv3.1\glassfish-3.1-b19-09_09_2010\glassfishv3\glassfish\bin\appclient.js(133,
      26) Microsoft JScript runtime error: 'length'
      is null or not an object

      • Invoking it with only '-client' gives NPE:

      D:\GFv3.1\glassfish-3.1-b19-09_09_2010\glassfishv3>glassfish\bin\appclient.bat
      -client
      java.lang.NullPointerException
      at
      org.glassfish.appclient.client.AppClientFacade.createContainer(AppClientFacade.java:436)
      at
      org.glassfish.appclient.client.AppClientFacade.prepareACC(AppClientFacade.java:260)

      Also, not really an issue, but the batch file includes:

      rem/*
      rem * To change this template, choose Tools | Templates
      rem * and open the template in the editor.
      rem */

        Activity

        Tim Quinn added a comment -

        setting target MS to MS 7.

        Tim Quinn added a comment -

        Fix checked in.

        The changes to fix this issue touched some of the same files I modified to
        address another problem. I fixed both at the same time. The repair for this
        issue itself did not affect all these files!

        Author: tjquinn
        Date: 2010-11-11 20:16:05+0000
        New Revision: 42743

        Modified:

        trunk/v3/appclient/client/appclient-scripts/src/main/resources/glassfish/bin/appclient

        trunk/v3/appclient/client/appclient-scripts/src/main/resources/glassfish/bin/appclient.bat

        trunk/v3/appclient/client/appclient-scripts/src/main/resources/glassfish/bin/appclient.js

        trunk/v3/appclient/client/appclient-scripts/src/main/resources/glassfish/bin/package-appclient

        trunk/v3/appclient/client/appclient-scripts/src/main/resources/glassfish/bin/package-appclient.bat
        trunk/v3/packager/nucleus-base/config/asenv.bat
        trunk/v3/packager/nucleus-base/config/asenv.conf

        Tim Quinn added a comment -
            • Issue 14160 has been marked as a duplicate of this issue. ***

          People

          • Assignee:
            Tim Quinn
            Reporter:
            Dies Koper
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: