glassfish
  1. glassfish
  2. GLASSFISH-13490

Difference between Metro on JRE and Metro in GF causes failures in Java Web Start client launches

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b30
    • Component/s: standalone_client
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      13,490

      Description

        Activity

        Tim Quinn added a comment -

        Setting target MS to MS 7.

        I had started some work with Ken C a while ago so that client class loading in
        Java Web Start would use the GlassFish-provided versions of these libraries.
        (Ken's work was not on Metro but on some ORB libraries.)

        Need to resume that work.

        Tim Quinn added a comment -

        Now that the forum has migrated, here is the link to the forum topic on the new
        site:

        http://www.java.net/forum/topic/glassfish/metro-and-jaxb/metro-20-incompatible-jre-6-causing-classnotfound-exceptions-0

        Tim Quinn added a comment -

        Todd, I have taken the liberty of adding you to the cc list for this issue
        that's tracking the problem you referred to in your forum post.

        Would you be able to download a recent build of GlassFish 3.1 and try your test
        again?

        Or, alternatively, if you are willing, you could attach your application to this
        issue?

        If you do that, please also let us know what steps you took to deploy the app
        and launch the client, including any special resource set-up etc. that we would
        need to do.

        This problem might be fixed. (A few of my own tests launching app clients that
        access web services have worked.) Some time ago we changed the class loading
        for Java Web Start-launched app clients that was intended to resolve this problem.

        Tim Quinn added a comment -

        Well, I did see this in my testing. I've checked in a fix for it that should be
        available in tonight's nightly build and the promoted build 30.

        Todd, can you please confirm that your example works using b30 once it's available?

        Two changes checked in:

        Author: tjquinn
        Date: 2010-11-15 19:18:18+0000
        New Revision: 42820

        Modified:

        trunk/v3/appclient/server/core/src/main/java/org/glassfish/appclient/server/core/jws/JWSAdapterManager.java

        Author: tjquinn
        Date: 2010-11-15 20:43:33+0000
        New Revision: 42828

        Modified:
        trunk/v3/appclient/client/acc/pom.xml

        Tim Quinn added a comment -

        Forgot to set the build to b30.


          People

          • Assignee:
            Tim Quinn
            Reporter:
            Tim Quinn
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: