glassfish
  1. glassfish
  2. GLASSFISH-13714

PWC1321: Error invoking requestInitialized method on ServletRequestListener org.jboss.weld.servlet.WeldListener

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_ms06
    • Component/s: cdi
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: Linux

    • Issuezilla Id:
      13,714

      Description

      Test name:ClientConversationContextTest

      Exception:
      =========
      [#|2010-09-
      30T11:16:45.951+0530|INFO|glassfish3.1|javax.enterprise.system.core.com.sun.ente
      rprise.v3.server|_ThreadID=15;_ThreadName=Thread-1;|CORE10010: Loading
      application jsr88-3411163934523370302.tmp done in 1 ms|#]

      [#|2010-09-
      30T11:16:46.751+0530|SEVERE|glassfish3.1|javax.enterprise.system.container.web.c
      om.sun.enterprise.web|_ThreadID=94;_ThreadName=http-thread-pool-
      8080(4);|WebModule[/test]PWC1321: Error invoking requestInitialized method on
      ServletRequestListener org.jboss.weld.servlet.WeldListener
      org.jboss.weld.context.NonexistentConversationException: WELD-000301 Could not
      restore long-running conversation org.jboss.jsr299 because id not known
      at
      org.jboss.weld.conversation.AbstractConversationManager.setupConversation(Abstra
      ctConversationManager.java:150)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.jav
      a:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at
      org.jboss.weld.bean.proxy.AbstractBeanInstance.invoke(AbstractBeanInstance.java:
      48)
      at
      org.jboss.weld.conversation.ServletConversationManager_$$_WeldProxy.setupConvers
      ation(ServletConversationManager_$$_WeldProxy.java)
      at
      org.jboss.weld.servlet.ServletLifecycle.restoreConversationContext(ServletLifecy
      cle.java:129)
      at
      org.jboss.weld.servlet.ServletLifecycle.beginRequest(ServletLifecycle.java:102)
      at
      org.jboss.weld.servlet.WeldListener.requestInitialized(WeldListener.java:182)
      at
      org.apache.catalina.core.StandardContext.fireRequestInitializedEvent(StandardCon
      text.java:4564)
      at
      org.apache.catalina.core.StandardContextValve.preInvoke(StandardContextValve.jav
      a:352)
      at
      org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:1
      60)
      at
      org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
      at
      org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
      at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
      at
      com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingS
      tandardPipeline.java:91)
      at
      org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
      at
      org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:326)
      at
      org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:227)
      at
      com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java
      :170)
      at
      com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:824)
      at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:721)
      at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1014)
      at
      com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:22
      0)
      at
      com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.
      java:135)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:102)
      at
      com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:88)
      at
      com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:76)
      at
      com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:53
      )
      at
      com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:57)
      at com.sun.grizzly.ContextTask.run(ContextTask.java:69)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:53
      0)
      at
      com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:511)
      at java.lang.Thread.run(Thread.java:619)

      #]

        Activity

        Sreekanth added a comment -

        Created an attachment (id=5020)
        Server log

        Sreekanth added a comment -

        Created an attachment (id=5021)
        war file

        Sreekanth added a comment -

        Created an attachment (id=5022)
        Client side report

        Sivakumar Thyagarajan added a comment -

        Targetting MS6 for this issue

        Sivakumar Thyagarajan added a comment -

        The ConversationTestPhaseListener that is part of this test, has references to
        org.jboss.weld.test.Utils. Unfortunately org.jboss.weld.test package is not part
        of weld-osgi-bundle and hence the submitter needs to add this package
        separately.

        [#|2010-10-
        19T19:53:04.216+0530|WARNING|glassfish3.1|javax.enterprise.system.container.web.
        com.sun.enterprise.web|_ThreadID=99;_ThreadName=http-thread-pool-
        8080(4);|StandardWrapperValve[Faces Servlet]: PWC1406: Servlet.service() for
        servlet Faces Servlet threw exception
        java.lang.NoClassDefFoundError: org/jboss/weld/test/Utils
        at
        org.jboss.weld.tests.contexts.conversation.ConversationTestPhaseListener.beforeP
        hase(ConversationTestPhaseListener.java:71)
        at com.sun.faces.lifecycle.Phase.handleBeforePhase(Phase.java:228)
        at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:99)
        at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
        at javax.faces.webapp.FacesServlet.service(FacesServlet.java:339)
        at
        org.apache.catalina.core.StandardWrapper.service(StandardWrapper.java:1522)
        at
        org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:2
        81)
        at
        org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:1
        75)
        at
        org.apache.catalina.core.StandardPipeline.doInvoke(StandardPipeline.java:655)
        at
        org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:595)
        at com.sun.enterprise.web.WebPipeline.invoke(WebPipeline.java:98)
        at
        com.sun.enterprise.web.PESessionLockingStandardPipeline.invoke(PESessionLockingS
        tandardPipeline.java:91)
        at
        org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:162)
        at
        org.apache.catalina.connector.CoyoteAdapter.doService(CoyoteAdapter.java:326)
        at
        org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:227)
        at
        com.sun.enterprise.v3.services.impl.ContainerMapper.service(ContainerMapper.java
        :170)
        at
        com.sun.grizzly.http.ProcessorTask.invokeAdapter(ProcessorTask.java:817)
        at com.sun.grizzly.http.ProcessorTask.doProcess(ProcessorTask.java:718)
        at com.sun.grizzly.http.ProcessorTask.process(ProcessorTask.java:1007)
        at
        com.sun.grizzly.http.DefaultProtocolFilter.execute(DefaultProtocolFilter.java:22
        5)
        at
        com.sun.grizzly.DefaultProtocolChain.executeProtocolFilter(DefaultProtocolChain.
        java:137)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:104)
        at
        com.sun.grizzly.DefaultProtocolChain.execute(DefaultProtocolChain.java:90)
        at
        com.sun.grizzly.http.HttpProtocolChain.execute(HttpProtocolChain.java:79)
        at
        com.sun.grizzly.ProtocolChainContextTask.doCall(ProtocolChainContextTask.java:54
        )
        at
        com.sun.grizzly.SelectionKeyContextTask.call(SelectionKeyContextTask.java:59)
        at com.sun.grizzly.ContextTask.run(ContextTask.java:71)
        at
        com.sun.grizzly.util.AbstractThreadPool$Worker.doWork(AbstractThreadPool.java:53
        2)
        at
        com.sun.grizzly.util.AbstractThreadPool$Worker.run(AbstractThreadPool.java:513)
        at java.lang.Thread.run(Thread.java:619)
        Caused by: java.lang.ClassNotFoundException: org.jboss.weld.test.Utils
        at
        org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1518
        )
        at
        org.glassfish.web.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1368
        )
        ... 30 more

        Sivakumar Thyagarajan added a comment -

        Marking this as closed as adding weld-core-test-1.1.0.Beta1.jar to
        domains/domain1/lib gets past this issue.


          People

          • Assignee:
            Sivakumar Thyagarajan
            Reporter:
            Sreekanth
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: