Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: v3.0.1
    • Fix Version/s: not determined
    • Component/s: deployment
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

    • Issuezilla Id:
      13,861

      Description

      I am using Maven projects to create deployment plan JAR files for our various
      environments. I found out if the maven puts the META-INF/maven/** directory
      into the deployment plan JAR file, executing the asadmin command will fail with
      the following exception:

      com.sun.enterprise.admin.cli.CommandException: remote failure: Exception while d
      eploying the app : java.lang.NullPointerException

      I was able to modify my POM and exclude the META-INF/maven/** directory from the
      deployment plan JAR file. When I did this, executing the asadmin command to
      deploy my application worked fine.

      This is nasty little bug which fails with no explanation as to why it failed and
      tracking it down to the META-INF/maven/** directory took quite a long time.

        Activity

        Bill Shannon added a comment -

        This has nothing to do with the CLI and everything to do with deployment.

        Hong Zhang added a comment -

        this is a similar problem as issue 13235 which was fixed in 3.1 build 22.

            • This issue has been marked as a duplicate of 13235 ***

          People

          • Assignee:
            Hong Zhang
            Reporter:
            mjremijan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: