glassfish
  1. glassfish
  2. GLASSFISH-13891

Nodes: ambiguous location for node directory

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_dev
    • Component/s: admin
    • Labels:
      None
    • Environment:

      Operating System: All
      Platform: All

      Description

      build: glassfish-3.1-b23-10_07_2010.zip

      When creating new nodes the following options are displayed:

      Node Directory:
      Points to the parent directory of the node(s) directory

      Installation Directory :
      Installation directory of GlassFish on local machine.

      The above does not specify where the node directory will be created, if
      specified by user. From my testing on localhost, where I specify installation
      directory as: $

      {com.sun.aas.installRoot}

      , the node directory (that I called
      mynodes) was created under domains/domain1/config:

      lancer(j2eetest):/export/home/j2eetest/v3.1/glassfish3/glassfish# find . -name
      lancer
      ./domains/domain1/config/mynodes/lancer

      It does not look like a good, default location. My expectation from the help
      text on New Node page would be that "mynodes" would be created directly under
      install directory. We should either change the behaviour or update the inline
      help, so it is clear to the user where the node directory will be created.

        Activity

        lidiam added a comment -

        Created an attachment (id=5106)
        server.log

        Anissa Lam added a comment -

        I need Joe to clarify the different directory.
        Please clarify what is the expected behavior and provide GUI with the inline
        help text so user will not be confused.

        Add your inline help text here in this issue and transfer back to GUI so i can
        take care of it, thanks

        Joe Di Pol added a comment -

        Looks like we need to:

        1) Decide what location a relative nodedir is relative too. I agree with the
        submitter that this should be glassfish3/glassfish.

        2) Fix the implementation to put them there. This could either be done in
        create-instance (construct and pass a full path for nodedir to
        _create-instance-filesystem), or in _create-instance-filesystem (always root
        nodedir relative paths to the install directory).

        3) Clarify what should be in the console inline help

        Joe Di Pol added a comment -

        If the nodedir is a relative path it is now rooted in the glassfish install root
        directory so if you use "mynodes" it is in /opt/glassfish3/glassfish/mynodes.

        Author: jfdipol
        Date: 2010-11-03 17:25:46+0000
        New Revision: 42425

        Modified:

        trunk/v3/admin/config-api/src/main/java/com/sun/enterprise/config/serverbeans/Node.java

        trunk/v3/admin/config-api/src/main/java/com/sun/enterprise/config/serverbeans/Servers.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/CreateInstanceCommand.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/DeleteInstanceCommand.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/InstanceDirUtils.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/ListNodesHelper.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/NodeUtils.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/StartInstanceCommand.java

        trunk/v3/cluster/admin/src/main/java/com/sun/enterprise/v3/admin/cluster/UpdateNodeConfigCommand.java

        trunk/v3/cluster/ssh/src/main/java/org/glassfish/cluster/ssh/connect/NodeRunner.java

        Log:
        Fix:
        13891 Nodes: ambiguous location for node directory
        14206 update-node-ssh/update-node-config qwerty, replace null with real name

        Also:
        Remove trailing comma from list of instances that are using a node in
        list-nodes and in delete-node. Change exception in NodeRunner so that
        if asadmin is not executable it gives you the path.

        Joe Di Pol added a comment -

        Marked as fixed.

        lidiam added a comment -

        Verified in download build, b43, web distro.


          People

          • Assignee:
            Joe Di Pol
            Reporter:
            lidiam
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: