glassfish
  1. glassfish
  2. GLASSFISH-13903

elements in tree and table displayed in random(?) order

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.1_b27
    • Component/s: admin_gui
    • Labels:
      None
    • Environment:

      Operating System: Windows XP
      Platform: All

    • Issuezilla Id:
      13,903

      Description

      When I create three JDBC Resources, 'jdbc/ab', 'jdbc/abc' and 'jdbc/abcd', in
      that order, I see them being displayed in the tree in the following order"
      jdbc/ab
      jdbc/abcd
      jdbc/abc
      jdbc/__TimerPool
      jdbc/__default

      Alphabetical order, or some kind of order (enabled first, disabled last, etc.)
      would make it easier to manage big numbers of elements.

      I haven't checked with GFv2.1 so not sure if this is a regression or RFE.
      Also, I haven't checked whether other elements (applications, etc.) have the
      same issue.

      Tested with glassfish-3.1-b24-10_09_2010 in IE8.

        Activity

        Anissa Lam added a comment -

        This is a general issue with admin console now.
        We get the inform from admin backend and never do any sorting. Using CLI may
        have the same issue.

        Also, sorting should be done in the right hand panel where the table lists the
        elements. Should take care of it with this bug too.
        getChildList() and getChildrenNamesList() in RestApiHandlers should sort before
        returning the list.
        Request Siraj to look into this.

        Anissa Lam added a comment -
            • Issue 13923 has been marked as a duplicate of this issue. ***
        Anissa Lam added a comment -

        I have done that to the table. will finishing up for the tree node.

        Anissa Lam added a comment -

        I have added sorting to the RestApiHandler that return the list for creating tables of just the children
        name.
        I haven't done that to the tree.
        For the tree, probably should do the sorting around line# 168 in ListTreeAdapter.java
        _children = (List<Object>) val;

        Anissa Lam added a comment -

        Since the table is sorted, will finish the tree in ms7.
        Actually maybe Siraj is working on that already.

        Anissa Lam added a comment -

        All Tables and tree nodes should be sorted now.
        If there is anything thats not, please file separate bug.


          People

          • Assignee:
            Anissa Lam
            Reporter:
            Dies Koper
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: